mIRC Home    About    Download    Register    News    Help

Print Thread
unable to join channel (not using secure connectio #269707 18/12/21 09:16 PM
Joined: Dec 2021
Posts: 2
M
MarquezB Offline OP
Bowl of petunias
OP Offline
Bowl of petunias
M
Joined: Dec 2021
Posts: 2
I've used MIRC for years without any major issues and I'm by no means a tech wizard BUT recently on a single channel I try to join I received the below message:

'unable to join channel (not using secure connection)'

I saw there was a newer version of MIRC so I downloaded that and re-booted but error still persists. Not sure what's causing this and seems to be specific to one or two channels. Any input or assistance or direction is GREATLY appreciated!

Thank you!

Re: unable to join channel (not using secure connectio [Re: MarquezB] #269708 19/12/21 01:43 PM
Joined: Jan 2004
Posts: 1,352
L
Loki12583 Online
Hoopy frood
Online
Hoopy frood
L
Joined: Jan 2004
Posts: 1,352
You need to connect to the server with ssl. Find and connect to it. Default is +6697

Re: unable to join channel (not using secure connectio [Re: Loki12583] #269749 10/01/22 06:00 PM
Joined: Dec 2021
Posts: 2
M
MarquezB Offline OP
Bowl of petunias
OP Offline
Bowl of petunias
M
Joined: Dec 2021
Posts: 2
My default port setting in MIRC options is already set to 6667 and I have the newest version of MIRC. I'm not super computer savvy but have had no other issues with MIRC for years so I'm scratching my head. I even tried to create a new SSL certificate in MIRC Options but again I'm just lost on this issue and would appreciate any help or additional direction you can offer.

Again the issue is that I am receiving error message when go to connect on a channel of "unable to join channel (not using secure connection"

THANK YOU in advance!

Re: unable to join channel (not using secure connectio [Re: MarquezB] #269750 11/01/22 12:31 AM
Joined: Jan 2004
Posts: 1,774
maroon Offline
Hoopy frood
Offline
Hoopy frood
Joined: Jan 2004
Posts: 1,774
The server lets channels know whether you connected with an SSL connection or not, and the channel has chosen to block people unless they do that.

Most networks have port 6667 as a regular non-secure connection.
When networks support a secure SSL connection, they usually tell the port numbers in the MOTD (message of the day) display you see at connection when you were connecting at 6667. The port number for that is often at 6697.

When you edit the serverlist entry to connect using the secure protocol, you should precede the port number with the "+", so where it currently has 6667 you should put in +6697 instead of just 6697. If you don't have the + there, it tries a normal connection at the secure port, and big fail.