mIRC Home    About    Download    Register    News    Help

Print Thread
Changing host name and IP address #266808 09/02/20 09:43 PM
Joined: May 2010
Posts: 45
B
BenderUnit Offline OP
Ameglian cow
OP Offline
Ameglian cow
B
Joined: May 2010
Posts: 45
I've just updated from 7.57 to 7.59 (so no idea if this issue was already present since 7.58 or not).
My situation is as follows: I leave the computer running 24/7 and also mIRC. I am also in a permanent DCC Chat with an Eggdrop, so every time I restart the computer and/or mIRC, I start a DCC Chat with this Eggdrop. This Eggdrop is running on the local network which is a NAT'ed network (with properly forwarded ports at the router) and so has an internal IP address. I also need to be able to DCC Chat (or send) to external publicly routable IP addresses.

So, in the settings in Connect->Local I leave the IP address set to my external IP so the NAT traversal works when wanting to connect to external addresses. But as I said, I'm also in permanent DCC Chat with this one locally running Eggdrop bot, so, upon starting mIRC and connecting to IRC, I go to Connect->Local, change the IP to my internal IP address of the computer running mIRC, open the DCC Chat with this Eggdrop and then once the chat is established I go back to the settings and change the IP back to my external IP so that everything continues to work afterwards for external connections.

Now here comes the issue: These settings don't take anymore since the update. I change the IP address and press OK to close the dialog window but its still set to the IP that was originally filled in... it simply wont take the change anymore whereas before this was never an issue.

In the meantime I thankfully found a workaround, which is to run simply "/localinfo" with no parameters, this changes the IP to my internal one, I do the DCC Chat and then I run "/localinfo <my-external-ip>" so that DCC Chatting to external bots work too.

Should you wonder why I'm doing it this way, its because of NAT timeouts that happen if I just simply leave it set to my external IP to connect to the locally running bot, the connection dies after a while and doing this prevents that and also prevents the connection from needing to pass through the router (which for this bot is absolutely unnecessary), which is also nice.

Re: Changing host name and IP address [Re: BenderUnit] #266810 10/02/20 08:34 AM
Joined: Dec 2002
Posts: 4,792
Khaled Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 4,792
Thanks for your bug report. I have not been able to reproduce this issue. As far as I can tell, there have been no changes to the way local info settings are stored or used.

Can you describe, step by step, how to reproduce your issue? For example, here is what I am trying:

1) Open the Options dialog.
2) Go to the local info section.
3) Type in a valid IP address, such as 127.0.0.1, in the IP address editbox.
4) Press the OK button.

If I then open the Options dialog again, the IP address is still there.

If I exit mIRC and run it again, and repeat the above, the IP address is still there.

If I go to the Options dialog and change the IP address, it is saved, as above.

Re: Changing host name and IP address [Re: Khaled] #266817 12/02/20 02:27 PM
Joined: May 2010
Posts: 45
B
BenderUnit Offline OP
Ameglian cow
OP Offline
Ameglian cow
B
Joined: May 2010
Posts: 45
You must also first connect to an IRC server, then try and change the IP. Other than that, those are exactly the same steps I'm doing.
Make sure there is already something filled in, though, like 127.0.0.1, then connect to an IRC server (I'm using TLS but this should not matter) and then try to change it to for example 127.0.0.2 and press OK. If you then open the options dialog again it should still say 127.0.0.1 instead of the new 127.0.0.2 address.

1) Start mIRC
2) Go check Options->Connect->Local settings to see that there is already an IP filled in, for example 127.0.0.1 and click Cancel to back out of it.
3) Connect to an IRC server (I'm using TLS although this shouldn't matter)
4) Go to Options->Connect->Local and change the IP to 127.0.0.2 and click OK
5) Go check the options again and you should see that the old IP 127.0.0.1 is still there instead of the newly entered IP 127.0.0.2

Re: Changing host name and IP address [Re: BenderUnit] #266818 13/02/20 10:19 AM
Joined: Dec 2002
Posts: 4,792
Khaled Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 4,792
Thanks, I was able to reproduce this issue. It has been fixed for the next version.

Re: Changing host name and IP address [Re: Khaled] #266825 14/02/20 02:31 PM
Joined: May 2010
Posts: 45
B
BenderUnit Offline OP
Ameglian cow
OP Offline
Ameglian cow
B
Joined: May 2010
Posts: 45
Oh, great news, thank you!