mIRC Home    About    Download    Register    News    Help

Topic Options
#237368 - 28/04/12 01:29 PM NNScript
Sove Offline
Bowl of petunias

Registered: 28/04/12
Posts: 2
Yes, I'm aware this script hasn't been updated in years, but the problem exists in fully compatible mIRC version (6.34) as well.

"You don't have writing privileges in the NNScript directory"

Everytime that happens on startup, I need to reinstall 6.34, NNS and then update the NNS enabled mIRC to the newest and then add the compatibility fixes.

None of the updating and compatibility fixes are causing this, btw. It happens even if I use 6.34.

Top
#237369 - 28/04/12 02:03 PM Re: NNScript [Re: Sove]
maroon Offline
Hoopy frood

Registered: 12/01/04
Posts: 1057
You didn't say what is the dir you don't have write privileges.
My guess is you're using Vista or Win7, and you've got mirc installed into a folder beneath c:\program files\ and are keeping the .ini in the same folder as mirc.exe itself, and the OS isn't permitting you to write to that folder. Starting with Vista the OS restricted programs' ability to write into c:\program files\ folder tree.

Try having mirc be instead installed into c:\mirc\ or c:\anywhere\else\mirc\ (you also save yourself from some poorly written scripts if you have mirc in a pathname that doesn't contain spaces.) You might also alter the icon from which you run mirc to have the "run as administrator" button checked, but that's probably not the best choice in the long run.

Another option is that if you install mirc fresh into a new folder that doesn't already contain your mirc.ini and other ini's, then mirc will use a roaming folder beneath your userid\appdata\ where you will have write privileges.

You can most likely see which folder mirc is using with: //echo -a $mircdir
Your NNscript dir will likely be either that or a folder beneath it.

Top
#237376 - 28/04/12 07:52 PM Re: NNScript [Re: maroon]
Sove Offline
Bowl of petunias

Registered: 28/04/12
Posts: 2
I have never had NNS-mIRC installed into program files as I am perfectly aware how bad that folder has become since Vista. The NNS-mIRC was originally in Documents/mIRC and NNS was installed in Roaming. It worked for a year and then it just started to give me that error.

Now NNS-mIRC is installed in Documents/NNSmIRC and so is the NNS, nothing is in Roaming. I have checked the privileges and I have full privileges.

I have tried to run as an administrator, but it has no effect. I also unloaded all other scripts and it didn't help either.

Is it possible that the script has problems with UAC and disabling it would help? I am hesitant to do this unless it has a high chance of success, if it fails, I need to reinstall the stuff again, which takes a nice bunch of time.

Top
#237377 - 28/04/12 07:56 PM Re: NNScript [Re: Sove]
sparta Offline
Planetary brain

Registered: 22/02/03
Posts: 3432
Loc: Sweden/Borlänge
try disable UAC and test, if it work then you know, if not just enable UAC again..
_________________________
if ($me != tired) { return } | else { echo -a Get a pot of coffee now $+($me,.) }

Top
#241743 - 24/05/13 10:17 PM Re: NNScript [Re: Sove]
vartaxe Offline
Bowl of petunias

Registered: 10/11/07
Posts: 2
someone should bring back nnscript to life! best script ever!

Top