mIRC Home    About    Download    Register    News    Help

Print Thread
Page 1 of 2 1 2
Joined: Nov 2011
Posts: 15
J
jomalin Offline OP
Pikka bird
OP Offline
Pikka bird
J
Joined: Nov 2011
Posts: 15
I'm using Win7 64 bits Professional Sp1, in spanish language.

2 bugs in mIRC options, Sounds, Speech:

1. The Help button does nothing. But I see this help is really in the mirc.chm file, but that button does not open it.

2. When I press the Options button to configure the Speech and I do my changes, press OK button, and OK button again... I come back and my options are never saved. So I cannot change the speech language por example.

Joined: Nov 2011
Posts: 15
J
jomalin Offline OP
Pikka bird
OP Offline
Pikka bird
J
Joined: Nov 2011
Posts: 15
Any ideas Khaled? Will this get fixed? I need to set the speech language to Spanish please

Joined: Oct 2003
Posts: 3,918
A
Hoopy frood
Offline
Hoopy frood
A
Joined: Oct 2003
Posts: 3,918
Where do you see a help button in the Speech options?

And report the results of the following command:

//echo -a $version $os $md5($mircexe,2) $file($mircexe).sig $dll(0) $script(0)


- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"
Joined: Feb 2011
Posts: 417
K
Pan-dimensional mouse
Offline
Pan-dimensional mouse
K
Joined: Feb 2011
Posts: 417
Originally Posted By: argv0
Where do you see a help button in the Speech options?


Tools -> Options -> Sounds -> Speech
You should see an "OK" "Cancel" and the "HELP" button.

If you like, I'll take a print screen, with directions.

(I can also confirm that the button does not open the help file, while under "Speech" in the treebar of the Options panel).

Tools -> Options -> Sounds (Help button works)
Tools -> Options -> Sounds -> Request (Help button works)
Tools -> Options -> Sounds -> Speech (Help button does NOT works)

mIRC 7.22 WindowsXP SP3

Joined: Oct 2003
Posts: 3,918
A
Hoopy frood
Offline
Hoopy frood
A
Joined: Oct 2003
Posts: 3,918
Oh I see, funny how I never really noticed the Help button there. Ever. I was looking inside the dialog pane.


- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"
Joined: Nov 2011
Posts: 15
J
jomalin Offline OP
Pikka bird
OP Offline
Pikka bird
J
Joined: Nov 2011
Posts: 15
Don't forget also the other bug... It makes impossible to change the speech language (I'm spanish). argv0, in a few hours I will post that command (I am not at home now)

Last edited by jomalin; 17/02/12 12:58 PM.
Joined: Dec 2002
Posts: 344
D
Pan-dimensional mouse
Offline
Pan-dimensional mouse
D
Joined: Dec 2002
Posts: 344
Originally Posted By: jomalin
Don't forget also the other bug... It makes impossible to change the speech language (I'm spanish). argv0, in a few hours I will post that command (I am not at home now)


mIRC uses Windows 7's built-in text to speech system, so if you want other languages you will need to add additional voices to it. I don't know anything about where to get good quality voices, but you can find the settings I'm talking about by searching for 'text to speech' in control panel.

Joined: Oct 2003
Posts: 3,918
A
Hoopy frood
Offline
Hoopy frood
A
Joined: Oct 2003
Posts: 3,918
I didn't forget about it, but you need to post the data before we can get anywhere; I can't reproduce the issue with settings not being saved.


- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"
Joined: Nov 2011
Posts: 15
J
jomalin Offline OP
Pikka bird
OP Offline
Pikka bird
J
Joined: Nov 2011
Posts: 15
Originally Posted By: argv0
And report the results of the following command:

//echo -a $version $os $md5($mircexe,2) $file($mircexe).sig $dll(0) $script(0)


It shows me:
7.22 7 157e5a5cafbe62d384ca9536966cc364 fail 0 1

Looks like ".sig" fails on Windows 7! That is another bug? All the properties of $file works except "sig". These are all executed in my mIRC 7.22:

//echo -a $file($mircexe).size --> 3256408
//echo -a $file($mircexe).ctime --> 1323303119
//echo -a $file($mircexe).mtime --> 1318526031
//echo -a $file($mircexe).atime --> 1323638764
//echo -a $file($mircexe).shortfn --> C:\PROGRA~2\mIRC\mirc.exe
//echo -a $file($mircexe).longfn --> C:\Program Files (x86)\mIRC\mirc.exe
//echo -a $file($mircexe).attr --> a
//echo -a $file($mircexe).sig --> fail

Executing mIRC with administrator privileges does the same, the "sig" fails.

Last edited by jomalin; 18/02/12 12:00 PM.
Joined: Dec 2002
Posts: 344
D
Pan-dimensional mouse
Offline
Pan-dimensional mouse
D
Joined: Dec 2002
Posts: 344
Originally Posted By: jomalin
Originally Posted By: argv0
And report the results of the following command:

//echo -a $version $os $md5($mircexe,2) $file($mircexe).sig $dll(0) $script(0)


It shows me:
7.22 7 157e5a5cafbe62d384ca9536966cc364 fail 0 1

Looks like ".sig" fails on Windows 7! That is another bug? All the properties of $file works except "sig". These are all executed in my mIRC 7.22:

//echo -a $file($mircexe).size --> 3256408
//echo -a $file($mircexe).ctime --> 1323303119
//echo -a $file($mircexe).mtime --> 1318526031
//echo -a $file($mircexe).atime --> 1323638764
//echo -a $file($mircexe).shortfn --> C:\PROGRA~2\mIRC\mirc.exe
//echo -a $file($mircexe).longfn --> C:\Program Files (x86)\mIRC\mirc.exe
//echo -a $file($mircexe).attr --> a
//echo -a $file($mircexe).sig --> fail

Executing mIRC with administrator privileges does the same, the "sig" fails.


It's not a bug. The correct MD5 hash for the 7.22 mirc.exe is 912dfaee60f144853a33231688312686. Your mirc.exe file has either been modified or corrupted.

I'd suggest downloading the mIRC installer directly from mirc.com and installing it over your installation so that it will replace the file.

Did you originally download mIRC 7.22 from a source other than mirc.com?

Joined: Nov 2011
Posts: 15
J
jomalin Offline OP
Pikka bird
OP Offline
Pikka bird
J
Joined: Nov 2011
Posts: 15
mIRC 7.22 reinstalled from the official website, now it gives me that:

7.22 7 912dfaee60f144853a33231688312686 ok 0 1

Please, correct the Help button "link".


These are all the language I got in the combo:


Sloveninan is the default, I don't know why... My Win7 is spanish. If I try to save it with Spanish and press the OK button, it does nothing, when I come back to that combo, Slovenian is always selected.

Last edited by jomalin; 18/02/12 06:17 PM.
Joined: Oct 2003
Posts: 3,918
A
Hoopy frood
Offline
Hoopy frood
A
Joined: Oct 2003
Posts: 3,918
I can't reproduce this. Setting my language to Spanish saves just fine, and the default language is English as per my Windows install.

Instead of installing mIRC over an existing broken install, completely uninstall mIRC (you can backup your settings and scripts to somewhere safe if you like) and install a completely fresh copy. Make sure to uninstall first, though. If it doesn't work then, it might be an issue with your OS environment. Not ruling out a bug, but it's likely that if it is a bug, it could be specific to regional versions of Windows (like your Spanish copy). It could also just be an issue with other corrupt/broken files on your machine, which would not be mIRC's fault.

FYI, I don't have the "Agents" dialog button showing in my mIRC, this either means the version is incorrect, or, more likely, I simply don't have Agents installed and you do. Of course, having Agents installed means one of two things: your Windows install is an upgrade from XP, not a fresh install, or you manually installed MS Agents after installing Win7. Either way, MS Agents *could* be the cause of the speech options not properly saving. I would suggest uninstalling agents if you are not using the feature, as it is deprecated in favor of the new speech options. Try this *after* trying a clean mIRC install, though.


- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"
Joined: Dec 2002
Posts: 5,170
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 5,170
Thanks for the bug report. The Help button issue has been fixed for the next version. The language feature depends on whether you have installed the required language files for Microsoft Agent. You have most likely installed the English language version which is "lhttseng.exe". The Spanish language version is "lhttsspe.exe" which you will need to find through Google as Microsoft no longer offers these files for download as far as I can tell.

Joined: Nov 2011
Posts: 15
J
jomalin Offline OP
Pikka bird
OP Offline
Pikka bird
J
Joined: Nov 2011
Posts: 15
My Windows 7 64 bits Professional is a fresh install, I NEVER do an upgrade from a previous OS...

Hey! I have found the bug. I have installed mIRC 7.22 from the official website in a fresh spanish XP SP3 install and the bug also persists.

This is the bug: When I select a language, mIRC saves just the previous one!! So, if the language list is:

...
Esloveno
Español
Euskera
...

and I select "Euskera" and press OK button, now "Español" is saved! This is why "Esloveno" is the selected default language is a Spanish OS (mIRC just saves the previous one). Programmatically speaking, can this a bug related to the index retrieving the language list from an array?

Please correct it. Thanks!

Last edited by jomalin; 25/02/12 11:32 AM.
Joined: Oct 2003
Posts: 3,918
A
Hoopy frood
Offline
Hoopy frood
A
Joined: Oct 2003
Posts: 3,918
I still can't reproduce this "bug". If you didn't perform an upgrade from a previous OS you should not have MS Agents installed on your machine. Windows 7 no longer ships with Agents, you had to have manually installed it. Did you manually install agents?


- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"
Joined: Nov 2011
Posts: 15
J
jomalin Offline OP
Pikka bird
OP Offline
Pikka bird
J
Joined: Nov 2011
Posts: 15
Originally Posted By: argv0
Did you manually install agents?


Yes, I installed MS Agents some weeks ago, trying to get the Spanish language...

But I don't think this is the problem, as I told, I have installed mIRC 7.22 in a fresh XP Professional SP3, this time WITHOUT installing MS Agent and I get the same problem with the languages combo.

Can someone with a non english OS tell if he/she have the same bug? Probably this bug occurs in OS different from English

Last edited by jomalin; 26/02/12 08:54 AM.
Joined: Feb 2003
Posts: 3,432
S
Hoopy frood
Offline
Hoopy frood
S
Joined: Feb 2003
Posts: 3,432
Tested on my comp, swedish language on OS, changed speach to spanish, closed mirc and reopened it again, and i had no problem.

OS
Windows 7 x86


if ($me != tired) { return } | else { echo -a Get a pot of coffee now $+($me,.) }
Joined: Oct 2003
Posts: 3,918
A
Hoopy frood
Offline
Hoopy frood
A
Joined: Oct 2003
Posts: 3,918
Uninstall agents. You don't need agents to do text to speech in Windows 7. I feel like this is the underlying issue here.

By the way, Windows XP has agents installed by default (this was the whole point of my saying that Vista and 7 no longer ship with agents-- XP did).


- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"
Joined: Nov 2011
Posts: 15
J
jomalin Offline OP
Pikka bird
OP Offline
Pikka bird
J
Joined: Nov 2011
Posts: 15
Uninstalling Agents is not easy, it doesn't appear in the desinstallation program list... When I installed it, it doesn't ask me anything (installation path)...

Joined: Feb 2003
Posts: 3,432
S
Hoopy frood
Offline
Hoopy frood
S
Joined: Feb 2003
Posts: 3,432
google for it, im shure you will find out how to do it there..


if ($me != tired) { return } | else { echo -a Get a pot of coffee now $+($me,.) }
Page 1 of 2 1 2

Link Copied to Clipboard