I actually has this problem, and I checked to see if I by chance had checked that box in options. It seemed I didn't have, also as I remember I hadn't.
Anyway, apart from my bad grammar, I tried checking it, pressing ok, and saw the exact same behaviour, no difference. I then unchecked the box, and voila, suddenly I had no problems with seeing windows that should properly overlap mIRC.
so I'm trying to say, thanks for you advice, it gave me inspiration to work my problem out smile

no matter how you try to cover the sky with your hands - is the sky truly smaller than your grasp?