Sounds like you have set mIRC to be "on top".

Click on the main mIRC icon in the top left corner and see in the "On top" option is enabled, if so click on it to disable it, see if that were your problem.

If on top setting is not your issue, which windows are you talking about/trying to alt tab to, are those mIRC windows or different programs like chrome notepad etc?

#mircscripting @ == the best mIRC help channel