I can confirm that unchecking this window option did in fact clear out that border color in mirc:
settings > personalization > colors > Show accent color on the following surfaces -- uncheck "Title bars and window borders"

I can only assume that since I normally couple doing mirc upgrades when I reboot my pc for windows updates that an update enabled that option.
Thanks so much for the help, I was going crazy trying to decipher what setting changed to caused this for me.

Last edited by theraster; 24/10/21 11:09 PM.