Probably a bug but I'm posting here just in case.
I have a game which works with udp, so far the server was only running on an ipv4 connection, For a while now I have been connected via my phone acting as wifi... which gives me ipv6.
With 7.67 just released I ran the game to see if it worked on that new version, but it didn't work. I had hardcoded 127.0.0.1 for connecting a client locally when you were the server, so I fixed that to be based on $iptype($ip), which solved the issue for tcp ( the game also use tcp; if it's ipv6 I changed the loopback address to ::1 (or 0:0:0:0:0:0:0:1))
Now for udp, I can't get anything to work, using ::1 or 0:0:0:0:0:0:0:1 as the ip address there does not work at all, the server is created with
Code
/sockudp -k udpserversocketname <port>
where <port> is any valid port. And here is an associated on udpread event:
Code
on *:udpread:udpserversocketname:{
  echo -sg received info from $sock($sockname).saddr $sock($sockname).sport
}

With a simple client being like:
Code
/sockudp tempclient 0:0:0:0:0:0:0:1 <port> some data


Can anyone get udp socket to work with ipv6 connectivity?

Last edited by Wims; 02/10/21 09:17 PM.

Looking for a good help channel about mIRC? Check #mircscripting @ irc.swiftirc.net