Well, that indicates the problem is something in the SSL handling at your end, and isn't the problem with the server's side. is the version of OpenSSL as of 7.58, so you should see that same number for all versions through 7.61, since 7.62 upgraded to 1.1.1f aka, and 7.64 uses 1.1.1i.

Can you confirm that options/connect/options/ssl shows the trusted auth file being the cacert.pem which came with mirc?

//notepad $mircini

Does the [ssl] section show anything for the key= and cert= settings? mine doesn't

If that doesn't solve it, you can try another external DLL which "works for me"

The FiSH script is at https://syndicode.org/fish_10/ - You don't need to install or use the FiSH dll, but it does contain the 2 lib*.dll files from OpenSSL 1.1.1h, though that's older than the 1.1.1i used in v7.64. You could also get a new OpenSSL and steal the DLL's from it.

You can set your mirc settings to load the external DLL during startup:
//writeini -n $qt($mircini) ssl load 1
Then unzip the 2 LIB*.DLL's into the MIRC folder and restart mirc. (don't need to reboot)

That will change the filenames and version number shown in my original echo, and it uses that version of OpenSSL regardless what's contained inside mirc.exe