Ever since Freenode changed their rules about a year ago, I have had problems getting in rooms.

This is the message I get from the server:
"Cannot join channel (+r) - you need to be identified with services - see https://freenode.net/kb/answer/registration"

I have mIRC set up to sign me in automatically. I can't find this setting in the Options screen, it might be a script I copied and pasted. It works fine if I open the program fresh. The problem is whenever I put my computer to sleep and wake back up, all my rooms are disconnected and don't automatically reconnect.

The rooms all say: * Attempting to rejoin channel #roomname

How do I make mIRC log me back in automatically?