My friend runs an IRC server using InsplRCd and no one has had connectivity problems besides the usual.
I have been on this server for a few years now without no issue.
I was on chatting with friends then suddenly realized no one was seeing the text I was posting (almost like a shun) so I closed my client and reopened it only to find it gave me this error...

Looking up
Connecting to ( port 6697...
Connected. Now logging in...
Looking up your hostname...
Found your hostname ( -- cached
{normally connects, instead I get long pause}
Closing link: ( [Registration timeout]
Disconnected (Remote host closed socket).

Everyone else logging on to the irc server has not had this problem.
The irc admin is completely clueless why this is happening to me.

I had not changed my router settings or client settings. This literally just happened out of the blue.

I tried mIRC, xchat and chatzilla, on two different computers and all of those give me that same exact error when trying to connect. Mibbit would connect but no one was able to see my text and most commands wouldn't work like /msg, /nick and so on.

I am able to connect to all other IRC servers without any problem which leads me to believe it's his server being problematic.

Here are all the things I tried so far..
Reset router
setup IDENT and access to port 113 just in case..
ran tcptraceroute on 6697, nothing blocking me
checked router ports, all proper ones are open

Other things have been tried to no avail. It has to be his server somehow blocking me? We're both stumped.

Thanks, I greatly appreciate any ideas.