I agree that the speed difference is going to be negligible, but there should be a difference, since mIRC would have to evaluate the information provided in $+(.timer.command) before proceeding with the actual execution of the timer sequence, versus the 2nd version where .command is being used as a name, and mIRC doesn't need to evaluate this.

I think (although I haven't tested this) that the evaluation required in the first timer code would be done each time the timer runs, rather than just once, as would be the case with just the name.