The problem is (was) that 'any mode' does not include 'no mode' (because 'none' isn't really a mode, it's the lack of any mode). To solve your problem you can just check or uncheck both 'any mode' and 'no mode' (so long as you don't have one checked and the other not).

Spelling mistakes, grammatical errors, and stupid comments are intentional.