mIRC Home    About    Download    Register    News    Help

Print Thread
Unable to connect ot IRCHighway using SLL anymore #269756 15/01/22 07:45 AM
Joined: Jan 2022
Posts: 1
S
Shrek Offline OP
Mostly harmless
OP Offline
Mostly harmless
S
Joined: Jan 2022
Posts: 1
For years I have been using Mirc and one of the servers I connect to is irc.irchighway.net using port 6697 or 9999 so it's ssl encrypted. For some reason I can nolonger do this and Mirc either just disconnects straight away or gives me an error "unable to connect Timout" or "a software error cause a disconnection" (sorry don't have the exact message for the last error). I have tried reinstalling Mirc, disabling the client firewall but this hasn't made any difference. What is odd if I connect on the standard port 6696 (not encrypted) it will connect. I have tried Mirc on a different PC and get the same results. I have also tried a different IRC client (HexChat) which connects happily to irc.irchighway.net on ports 6697 or 9999 and ssl encrypts without any issues (from both my PC's).

Re: Unable to connect ot IRCHighway using SLL anymore [Re: Shrek] #269759 16/01/22 10:27 AM
Joined: Feb 2011
Posts: 403
K
KindOne Offline
Pan-dimensional mouse
Offline
Pan-dimensional mouse
K
Joined: Feb 2011
Posts: 403
What version of mIRC are you using?

Looks like the network has a self-signed cert.

Is your client set to "Skip connections with invalid certificates"?

Tools -> Options -> Connect -> Options -> SSL...


irc.swiftirc.net #msl (mIRC Scripting Language)
Re: Unable to connect ot IRCHighway using SLL anymore [Re: Shrek] #269760 16/01/22 05:58 PM
Joined: Jan 2004
Posts: 1,745
maroon Offline
Hoopy frood
Offline
Hoopy frood
Joined: Jan 2004
Posts: 1,745
Looks like there's 2 problems, and they're both on irchighway's side. They have a server which times out the connection, and another server with an invalid certificate.

You can temporarily avoid the problem by setting mirc to 'display invalid cert for approval' and when you see the prompt, you can check the box at bottom to auto accept that cert in the future.

Unfortunately, you probably will continue having trouble connecting to +6697 SSL because their individual server names don't have a dns reply,

Also, once you check the box to accept a cert in the future, that adds an item to your servers.ini, so if you've done that in the past, there's the potential to have scads of certificate fingerprints that you've collected

edit: I took out the instructions on how to connect to server ip's directly since they dont want us to do that. So i guess hope that you can eventually connect to one of the servers in the round robin that will actually present the invalid cert for approval instead of just timing out like the others


Last edited by maroon; 16/01/22 06:16 PM.