mIRC Homepage

7.68.933 - /me not displaying correctly.

Posted By: KindOne

7.68.933 - /me not displaying correctly. - 05/05/22 08:12 PM

Tested and replicated on Libera.Chat and Snoonet.

When I type:

Code
/me test


I get this on my screen:

* ACTION test

Copy/pasting the line into notepad++ includes the $chr(1) at the beginning and end.
Posted By: Khaled

Re: 7.68.933 - /me not displaying correctly. - 05/05/22 09:35 PM

Thanks for testing this.

For those not aware: this is related to the echo-message feature whose specification states that when an echo is received, the client should replace the message currently displayed in the window, ie. your own message, with the echoed message, since the echo may be changed in some way, eg. the server/channel might strip control codes, censor words, etc. so that you can see what the target actually received as the message.

Right, so this means that before replacing a line with its echo, the client will first need to check if the echo is using a format that needs to be parsed in a specific way, which in this case would be the CTCP ACTION format. But the echoed message needs to be re-parsed/displayed as if it is being sent, not received. Some CTCPs are displayed differently depending on context, so it's not as simple as just replacing the message, eg. PING is displayed differently depending on whether it is being sent, received, or replied to, SOUND is displayed differently depending on whether it is displayed in the status window or channel/query window, and all are displayed differently if they are sent using /raw, and so on.

It's also not clear how this would affect the display of messages customized by scripts.

I'm going to make a few changes to the next beta and we'll see how it goes from there.
© 2022 mIRC Discussion Forums