mIRC Homepage

Bind option bug

Posted By: Raccoon

Bind option bug - 19/03/21 08:43 PM

Relating to this thread...

mIRC does not seem to respect the checkbox "Bind to Adapter or IP address" when it is unchecked. The contents of the combo box is used regardless of this checkbox, even when the box is unchecked and the combo is grayed out.
Posted By: Khaled

Re: Bind option bug - 19/03/21 09:20 PM

Thanks for your bug report. I have not been able to reproduce this issue here so far. For example, if I check the bind checkbox and select an adapter, and then connect, mIRC tries to use that adapter. If I then uncheck the bind checkbox, mIRC reverts to using the default adapter chosen by Windows.
Posted By: Raccoon

Re: Bind option bug - 21/03/21 10:26 AM

When the bind checkbox is unchecked, but an adapter name is still in the combo box, and that adapter has been disabled through Windows network connection settings, is mIRC having a hiccup because the adapter can't be seen?

The errors I get are "* Unable to create socket" and "* Unable to resolve server" when toggling the checkbox, until I empty the combo box.
Posted By: Khaled

Re: Bind option bug - 21/03/21 12:02 PM

Quote
When the bind checkbox is unchecked, but an adapter name is still in the combo box, and that adapter has been disabled through Windows network connection settings, is mIRC having a hiccup because the adapter can't be seen?

Thanks, that was it. It wasn't finding the adapter in the first place, and combined with other settings, that was causing it to block further connections. This should be fixed in the next beta.
© 2021 mIRC Discussion Forums