mIRC Homepage

$emailaddr

Posted By: TECO

$emailaddr - 12/09/19 08:12 PM

If I type and have only one "." in the email address field, in mIRC options, when I try to connect to PTnet network I can't. This did not happen in the previous beta

[Linked Image from i.ibb.co]
Posted By: Khaled

Re: $emailaddr - 12/09/19 11:04 PM

Thanks for your bug report. There have been no changes related to this feature in a long time. The message you are seeing in the closing link message is a server message. If you use "/debug on" to view the raw server communication in the debug.log file, is mIRC sending the expected parameters during logon? What have you entered in the email address field? Is it a full email address?
Posted By: TECO

Re: $emailaddr - 12/09/19 11:35 PM

What I entered in the email field was a full stop. (.)
Posted By: Khaled

Re: $emailaddr - 12/09/19 11:43 PM

If you use "/debug on" to view the raw server communication in the debug.log file, is mIRC sending the expected parameters during logon?
Posted By: TECO

Re: $emailaddr - 12/09/19 11:48 PM

Originally Posted by Khaled
Thanks for your bug report. There have been no changes related to this feature in a long time. The message you are seeing in the closing link message is a server message. If you use "/debug on" to view the raw server communication in the debug.log file, is mIRC sending the expected parameters during logon? What have you entered in the email address field? Is it a full email address?


[Linked Image from i.ibb.co]
[Linked Image from i.ibb.co]
Posted By: Khaled

Re: $emailaddr - 12/09/19 11:56 PM

Do you have the "Use ID from email address" enabled in the Identd dialog? If so, identd is sending your userid as "." to the server when replying to its identd request. That is likely what the server is rejecting.
Posted By: TECO

Re: $emailaddr - 13/09/19 12:07 AM

Originally Posted by Khaled
Do you have the "Use ID from email address" enabled in the Identd dialog? If so, identd is sending your userid as "." to the server when replying to its identd request. That is likely what the server is rejecting.

Yes. I had this option active. I already disabled it and now it works even with period in the email field. Thank you!
© 2020 mIRC Discussion Forums