mIRC Homepage

Autoget fails - possible corrupted trust in list

Posted By: Protopia

Autoget fails - possible corrupted trust in list - 12/10/18 08:31 AM

I have Options / DCC with "Auto-get file" and in Trusted pop-up set both "Limit Auto-get to trusted users" and "Show get dialog for non-trusted users".

This has been working fine. However it stopped working after I added a trust, and started working again when I removed it and re-added it.

Unfortunately I did not save the configuration file containing the original trust definition and have not been able to recreate it. But it appears that the Auto-Get code may fail to work correctly in some circumstances, perhaps a corrupt entry.

I am not sure whether an examination of the Auto-Get code could identify the possible cause and get fixed. But if I don't report this you won't have the opportunity to fix it and if you can't stop the issue based on this information then nothing is lost.

I am just sorry that I cannot give you anything more to go on than this.
Posted By: Khaled

Re: Autoget fails - possible corrupted trust in list - 12/10/18 09:45 AM

Thanks for your bug report. Unfortunately, I can only test out a bug report if a reliable method of reproducing it is provided.
Posted By: Protopia

Re: Autoget fails - possible corrupted trust in list - 12/10/18 11:44 AM

That's what I thought you would say - but unfortunately I have not been able to reproduce it.

I suspect that if I hand edit the relevant mIRC control file I might be able to reproduce it somehow, but that seems somewhat artificial when I didn't do anything like that to create the issue the first time. I have retried the "/dcc trust" command I used to create the entry at issue, but was not able to recreate it.

So unless a code walkthrough of the Auto-get comes up with an obvious case where is mal-formed trust entry causes the loop to end early, there seems to be little we can do to take this further.
Posted By: BhaaL

Re: Autoget fails - possible corrupted trust in list - 12/10/18 12:31 PM

Taking a shot in the dark here, but the [trusted] section is at the very bottom of mIRC.ini (at least in my case).
Maybe there was no newline or something like that, and the entries got stuck together. Might as well be a non-mIRC issue where that newline was added/removed or even transformed into a LF-only newline, which in turn trips up mIRC?
Posted By: Protopia

Re: Autoget fails - possible corrupted trust in list - 12/10/18 12:40 PM

The mIRC UI for trust (Options / DCC / Trusted) works just fine - as does $trust - it is just Auto-Get which seems to have had an issue.
© 2020 mIRC Discussion Forums