mIRC Homepage

Clicking on a URL link in channel does nothing

Posted By: _entropy

Clicking on a URL link in channel does nothing - 05/11/17 08:11 PM

For some reason, since i updated Win10, i cannot double click links (on channel) and use the //run <site> command.
Posted By: WKN

Re: Clicking on a URL link in channel does nothing - 07/11/17 06:58 PM

Hi!

I can confirm this bug also for me.

In mIRC 7.49, URLs were clickable and opened the window for confirmation of open browser.
In mIRC 7.51, the URL is not even recognized, no change on hover like in before version.

Configuration: mIRC 7.51, Windows 10 1709

BR
wkn
Posted By: maroon

Re: Clicking on a URL link in channel does nothing - 07/11/17 08:38 PM

We were playing around with this in channel the other day. Can you confirm that the problem happens only when Firefox is the default browser, and doesn't happen with Chrome? If you're having problems with Firefox doing this, does it make the problem go away to close+reopen Firefox? Someone said the problem went away in the Firefox beta version 57, but I'm not certain whether that was just a result of closing and reopening Firefox.

We were also seeing the problem with
Code:
/run www.yahoo.com


so it appears to be a problem with interaction between mirc and the browser, and not specific to just the url window itself or the mouse.
Posted By: Khaled

Re: Clicking on a URL link in channel does nothing - 07/11/17 10:00 PM

Thanks for your bug report. I have not been able to reproduce this issue so far. When I double-click on links, such as http://www.mirc.com, in the status window in mIRC, it opens the link in the default browser. I tested with Microsoft Edge, Firefox, and Chrome.

Did you set the default browser using the Windows 10 Settings / Apps / Default Apps dialog?

If you install a clean copy of mIRC, using the "portable" option in the installer, into a new folder in your Windows documents folder and test it there, do you see the same issue?
Posted By: _entropy

Re: Clicking on a URL link in channel does nothing - 07/11/17 10:03 PM

Ok so i fixed it.. it was a FireFox issue. After i closed FF and then used /run <site>, it worked as expected.

Using: FireFox Version 56.0.2 (64-bit)
Posted By: WKN

Re: Clicking on a URL link in channel does nothing - 07/12/17 07:11 PM

Hi,

just updated to mIRC 7.51, i see same issue when doubleclick on URL, but also when doubleclick on a nick in channel. Nothing happens on URL, and on nick Channel central is shown. Doubleclick on nick in nicklist does normal query open. Hotlinks seems to be not recognized in the new version anymore.

Had no issues in mIRC 7.49 before in such cases.

BR
wkn
Posted By: maroon

Re: Clicking on a URL link in channel does nothing - 07/12/17 07:28 PM

WKN, can you confirm whether the issue remains after you close/reopen Firefox as entropy did, or set Chrome as default and check if the issue exists with Chrome, then change it back to Firefox?
Posted By: WKN

Re: Clicking on a URL link in channel does nothing - 07/12/17 07:58 PM

Hi maroon,

i changed standard browser to IE (normally it is FF), but still same issue. So i think it is not a browser thing. As i said, mIRC does not recognize links, when mouse over, the mouse pointer don't change.

When i make a /run www.mirc.com, browser opens and show the page (either FF or IE, both work).

BR
wkn
Posted By: maroon

Re: Clicking on a URL link in channel does nothing - 07/12/17 09:25 PM

Sorry, forgot to also mention to also verify options/irc/catcher has the option checked for 'enable catcher for url'.
Posted By: Khaled

Re: Clicking on a URL link in channel does nothing - 08/12/17 09:14 AM

Thanks for your bug report. I have not been able to reproduce this issue so far. If you type the following into mIRC status window and press the enter key:

Quote:
/echo This is a link: http://www.mirc.com

And then however your mouse over the link, does it change to a hand? If you right-click on it, do you see a popup menu? If you double-click on it, what happens?
Posted By: Wims

Re: Clicking on a URL link in channel does nothing - 08/12/17 09:57 AM

Quote:
As i said, mIRC does not recognize links, when mouse over, the mouse pointer don't change
This seems to indicate that you are using the on hotlink event in one of your script to handle the hotlinking yourself, and a bad script can quickly result in you not being able to open link anymore. Try typing /remote off in mIRC to disable all your scripts and see if you can click on url then, type /remote on to enable your scripts back
Posted By: WKN

Re: Clicking on a URL link in channel does nothing - 08/12/17 05:32 PM

Hi,

i have now tested all the advices you gave to me.

@Khaled: After issuing the /echo and hover over the link, the mouse pointer stays at arrow, no change into hand.
Right click on the link shows only Channel central in channel window.

@Wims: i switched off remote, no change in behaviour. I also took the pure install ( i install mIRC first in an extra directory and then after some small smoke test i copy it to my real mITC directory with the scripts in. But also in this clean install i have the described issue.

I am on Win10 1709, which i had installed shortly before update to mIRC 7.51

Edit: I now installed 7.49 again in an extra directory and run mIRC from there. It worked as expected again. Also doubleklick on nick in channel opens query.

BR
wkn
Posted By: Khaled

Re: Clicking on a URL link in channel does nothing - 08/12/17 06:33 PM

Unfortunately I have still not been able to reproduce this. I installed a clean copy of mIRC v7.51, using the "portable" option in the mIRC installer, in the Windows "Documents" folder, in Windows 7, 8, and 10. In all cases, the link worked.

If you install a clean copy of mIRC, using the "portable" option in the mIRC installer, into a new, empty folder in "Documents", and test the link, does it work?
Posted By: WKN

Re: Clicking on a URL link in channel does nothing - 10/12/17 05:33 PM

I have installed portable version of mIRC 7.51, and, don't ask why, it works. Even copied to my scripted mIRC directory.

I will stay on this install, although i could not explain. I istalled many times before wzthout success.

Thanks for your support :-)

BR
wkn
© 2019 mIRC Discussion Forums