mIRC Homepage

Typing lag mirc 6.35

Posted By: Shocky

Typing lag mirc 6.35 - 07/05/09 12:04 AM

Hello,

I have noticed a major and annoying problem with latest mirc 6.35.
I am using windows 7 RC1 so it could be that but someone told me he noticed the same thing on windows vista but since mirc 6.32 or so.

The problem is when i type actively in the editbox or channels or query, sometimes i never see my characters. I have to wait up to 15 seconds to see them "coming". So this is kinda wierd... Anybody else having this problem?

Thanks
Posted By: Wims

Re: Typing lag mirc 6.35 - 07/05/09 12:37 AM

More than weird, it not normal.
Window 7 could be the problem but I doubt it is the case here...
People on vista that noticed this too should try a clean mIRC 6.35 with no script loaded, usually script are cause of problems.
Posted By: argv0

Re: Typing lag mirc 6.35 - 07/05/09 12:47 AM

Are you pasting input? More specifically are you pasting unicode input? mIRC usually freezes the first time it tries to render unicode if your font does not support unicode and font linking is on (might still occur without font linking as well). Note the default font (fixedsys) does not support unicode.

Also, in mIRC type:

//echo -a $md5($mircexe,2) $script(0) $dll(0) $version $os

Report the results here.

If you're running any scripts you should reinstall a fresh copy of mirc without scripts and verify that it still happens.
Posted By: Shocky

Re: Typing lag mirc 6.35 - 07/05/09 01:06 AM

I am not pasting... it is during typing.
I currently have mircryption suite loaded as scripts.

Your command gives me:
877f45a0d205e409a7c2d4c87f03fe90 6 1 6.35 Vista

Thanks
Posted By: genius_at_work

Re: Typing lag mirc 6.35 - 07/05/09 05:10 AM

2f63a83968f9586fe4fb48134253619c 21 0 6.35 Vista
Posted By: argv0

Re: Typing lag mirc 6.35 - 07/05/09 06:43 AM

You've directly modified the mIRC executable which violates the EULA (license agreement). We cannot offer you support. Download mIRC from http://www.mirc.com and try this on a COMPLETELY FRESH install of mIRC with no scripts running. I have a good feeling that without mirccryption modifying what you send and receive from the server, mIRC will likely render text a lot more responsively.
Posted By: Excalibur

Re: Typing lag mirc 6.35 - 07/05/09 01:03 PM

No it isn't
I've been using Windows 7 for a long time and I had no issues with mIRC, it actually runs on Windows 7 as smooth as it runs on XP, if not better.
Posted By: RoCk

Re: Typing lag mirc 6.35 - 07/05/09 01:07 PM


Same here, no problems whatsoever on Win7.

~ Edit ~

x86 & x64

Posted By: vexed2

Re: Typing lag mirc 6.35 - 08/05/09 08:58 PM

I use mIRC 6.35 successfully on Windows 7 too. However, i noticed a typing lag on a script i started making, then while i was trying to work this out i also noticed on my dcx sbar, the timers were going up up 2's even though the timer was supposed to update every second. I don't know what the problem was to be exact, but i run AVG 8.5 so i set an exception to the whole mIRC directory C:\mIRCscript and clicked apply, and bingo! It fixed the typing lag and the delay in the timer. So obviously the realtime scanning must have had something to do with this and maybe it's because of how Windows 7 works now. I can't say with certainty, but it worked for me. smile
Posted By: kogitsune

Re: Typing lag mirc 6.35 - 16/06/09 04:21 AM

I have this same sort of issue... I've already posted to a topic someone started on the Windows 7 forum but there's no replies at all so far.

I know it's not scripts because... mine has none besides the defaults. Tried clean installs-- It happens to me in every version back to 5.16 or so.

We found that it's specifically related to when a channel window is made inactive either through minimizing, alt+tab, clicking on the start menu, or switching away from the window in any manner. If you go back to mIRC and type quickly, it'll lag and sometimes not display until you move the mouse.

It types and displays perfectly until this is done.

This behaviour is also specific to each channel window (It doesn't happen in unique channel windows until you switch to them and change the active window).

I run AVG, so I also tried the exception mentioned earlier in this thread. I've also attempted to run it on compatibility modes for XP SP3 (The previous OS I used), SP2, Vista, and for kicks 2000 and 95. It makes no effect.

Otherwise it works beautifully, I've seen no other issues. As stated, it could be something in Windows 7, since it didn't do this to me in XP SP3-- But as I pointed out... the old versions around 5.16 and below don't do this.

Just for sake:
I'm currently using 6.35 edition re-installed
I'm running a Phenom II X4 955 3.2Ghz quad, 4Gb RAM, Windows 7 build 7100 RC, Sapphire Radeon 4870HD, Western Digital Caviar SATA 620Gb HD.
Posted By: argv0

Re: Typing lag mirc 6.35 - 16/06/09 05:44 AM

@kogitsune: In mIRC type:

//echo -a $md5($mircexe,2) $script(0) $dll(0) $version $os

Report the results here.

Also disable AVG entirely (yes, entirely) and try this again. It's far more likely that your anti-virus software is causing the problem than mIRC.
Posted By: westor

Re: Typing lag mirc 6.35 - 17/06/09 02:31 PM

The same problem here with Windows XP SP3, getting lag on scripts!

3e9f2b048c960052d6230d4735c41622 8 1 6.35 XP
Posted By: Wims

Re: Typing lag mirc 6.35 - 17/06/09 02:34 PM

You don't have a real copy of mIRC 6.35, try download it on mirc.com.Also, unload your scripts and your dll, you really should try on a clean install.
Posted By: DJ_Sol

Re: Typing lag mirc 6.35 - 11/07/09 07:19 PM

I wonder what your computers specs are. Been using Vista for over a year and have never had this issue.
Posted By: argv0

Re: Typing lag mirc 6.35 - 11/07/09 08:19 PM

Both users who complained in this thread had modified versions of mIRC, so draw your own conclusions.
Posted By: Lusht

Re: Typing lag mirc 6.35 - 26/07/09 08:50 PM

Ok, I tired.
Same annoying problem here, details:
2f63a83968f9586fe4fb48134253619c 23 0 6.35 Vista (it's win7 x32 actually)
Also, additional details:
http://img233.imageshack.us/i/details.png/
Just clean install, it is not modified copy. UTF-8 encoding&decoding (per channel settings) disabled, only UTF-8 display enabled.

Btw, I noticed that when lagging starts such interesting thing happens:
http://img233.imageshack.us/my.php?image=graph.png

If I will quickly change window to text editor - everything fine, no lagging when typing...

P.S. Under Vista it worked fine with the same set of scripts. Also, I don't have script which monitors on INPUT events or editbox state.
Posted By: argv0

Re: Typing lag mirc 6.35 - 26/07/09 09:07 PM

How does a "clean install" contain 23 loaded scripts?

Any number of those 23 scripts could be the cause. Try with a *CLEAN* install of mIRC-- this means without any loaded scripts.

Alternatively you can unload scripts until the problem goes away (if it does)-- the last unloaded script would be the cause, at which point we can figure out if it's the script or some incompatibility between those commands and Windows7.
Posted By: Lusht

Re: Typing lag mirc 6.35 - 27/07/09 05:57 PM

Quote:
How does a "clean install" contain 23 loaded scripts?

I said it especially for you to prevent "oh-youre-using-modified-copy!" thingy.

Quote:
Any number of those 23 scripts could be the cause. Try with a *CLEAN* install of mIRC-- this means without any loaded scripts.

TRIED already. Same issue happens.
Posted By: argv0

Re: Typing lag mirc 6.35 - 28/07/09 05:19 AM

I don't understand your response. If you tried this without scripts why did your post explicitly discuss the results *with* scripts?
Posted By: Lusht

Re: Typing lag mirc 6.35 - 28/07/09 09:07 PM

Quote:
I don't understand your response.

We can help here:

Quote:
Try with a *CLEAN* install of mIRC-- this means without any loaded scripts.


Quote:
TRIED already. Same issue happens.
Posted By: OriginalTux

Re: Typing lag mirc 6.35 - 28/07/09 11:07 PM

I can confirm this from my side.

2f63a83968f9586fe4fb48134253619c 1 0 6.35 Vista

It's actually Windows 7 x64; and that 1 script that is loaded, is just the initial "remotes.ini" which is blank.

This issue only happens to me when the mouse pointer is idling on top of the docked channel windows in the switchbar, and I am typing something. CPU usage spikes to a peak of around 45%

This also happened on a different motherboard with a copy of Windows 7, so I originally thought that it was caused by my video cards (since I carried them over to the new setup).
Posted By: RRX

Re: Typing lag mirc 6.35 - 29/07/09 08:23 AM

Well, when you move the mouse to a clickable location, let it there, and start typing, what all happens on the moment that 'focus' changed?
As soon as you start typing, it (dunno what 'it' here is - windows itself?) makes the mouse cursor disappear, until you move it again.
So which other things may happen at that very moment of mouse cursor disappearance? Since mIRC shows a CPU usage peak, it does alot work there, what can that all be?
Posted By: Lusht

Re: Typing lag mirc 6.35 - 29/07/09 05:23 PM

Hm. I noticed weird thing. Lagging happens only if window (channel or/and status) doesn't have pop-up/ballon description hint, like this one:
http://img233.imageshack.us/my.php?image=laggingdesc.png

So, if I will move mouse cursor to the window with such balloon hint and start typing - everything seems to be fine (mouse cursor disappears in this case), but if I will move cursor to the window without hint (yeh, still keep typing at the same moment) - lagging happens and mouse cursor doesn't disappear.

Odd things is odd.
Tried to play with some mIRC/Windows related settings but no luck.
Posted By: Shocky

Re: Typing lag mirc 6.35 - 17/08/09 08:32 PM

seems you have found the trouble...
Posted By: argv0

Re: Typing lag mirc 6.35 - 18/08/09 01:46 AM

I forgot/lost track of this original report and ended up posting a duplicate here
© 2019 mIRC Discussion Forums