mIRC Homepage

$url crash

Posted By: Dromedary

$url crash - 17/08/06 06:34 PM

the new $url identifier added in 6.2 seems to work pretty good, but i have the problem where it causes a crash.

here's my scenerio:
opera is my default browser
i have firefox and internet explorer running
i do not have opera running

if i start opera, $url returns fine. if it's closed, mirc crashes. tested on both a highly scripted mirc, and just a plain vanilla install of mirc. reproducable on both.

my guess is that the function that finds the current opened url looks for a url, then doesn't find one. so it either doesn't return or returns null. then the other function that called it waits on a reply that it never gets, in the mean time keeping mirc.exe from processing any other commands.

complete guess though, but it doesn't appear to be an inf loop cuz the cpu usage doesn't go to 100%.

i haven't had time to try to reproduce in other ways, may try later. maybe this bug only appears if your default browser is opera, or maybe anything but internet explorer *shrugs*
Posted By: Dromedary

Re: bad $url bug - 17/08/06 06:50 PM

i tried overwriting the alias with

alias url {
return disallowed
halt
}

didn't help any.

added the halt just to see if it would make it work, didn't have any effect.
Posted By: Khaled

Re: $url crash - 20/08/06 02:46 PM

I can't seem to reproduce an issue here. I tested //echo $url with both Opera and Explorer, opening and closing them several times and checking the $url result each time, it worked fine every time for me. Which version of Windows are you using?
Posted By: PhantasyX

Re: $url crash - 20/08/06 03:22 PM

I have a question, is this supposed to only return the active URL in your default browser?

I noticed that for me, $URL is only returning the active URL from my firefox browser. (Unable to produce the url in IE, tryed both on 6.17 and 6.20)
Posted By: Khaled

Re: $url crash - 20/08/06 08:16 PM

That is correct, it returns the URL only for your default browser.
Posted By: Dromedary

Re: $url crash - 24/08/06 04:57 AM

i'm using windows xp sp1.

here is what i think is happening. opera is my default browser, so when i have just internet explorer open and i try $url it crashes. if i have opera opened it doesn't crash. if i have no browsers what-so-ever opened, it still crashes. this is completely reproducable when my default browser is switched to firefox and i try to get $url with firefox closed. if firefox is closed, like always, it runs error free.

don't know what would make my computer a special case compared to normal computers.. like i said, reproducable even with vanilla 6.2. you think maybe for some odd reason it may have to do with dual monitors? that's about the only thing kinda unqiue about my comp that i can think of.

edit: i just did the crash again watching it in the task manager. it doesn't do anything while in this crashed state. no I/O read or write byres, VM and ram usage stays the same, and no processor usage at all that i can see.
Posted By: Khaled

Re: $url crash - 24/08/06 05:51 PM

Unfortunately I am still unable to reproduce the issue here. I have installed Firefox, Opera, and have run all three browsers at the same time, closed them, etc. //echo $url seems fine for me. Perhaps you have some other software running in the background that is interfering in some way.

When you say mIRC "crashes", do you mean it actually crashes and reports an error message, or it freezes?
Posted By: Dromedary

Re: $url crash - 24/08/06 08:04 PM

it freezes and doesn't do anything. sorry for not clarifying. eventually the titlebar will say mIRC (not responding) and at any time after the freeze if you try to close it will say that the program is not responding, cancel or end now etc.
Posted By: Khaled

Re: $url crash - 27/08/06 01:12 PM

If mIRC is freezing, this sounds like the DDE freeze issue that users have reported in the past. If you are running a background application that does not handle DDE messages correctly, it can cause other applications that use DDE to freeze. As far as I know, there is no way to resolve this since it depends on other applications handling DDE messages correctly. You could try closing down background applications one by one to see if you can pinpoint which one is causing the issue.
© 2021 mIRC Discussion Forums