mIRC Homepage

.----'-/'-/ Unknown command

Posted By: turboke

.----'-/'-/ Unknown command - 06/06/04 02:55 PM

I upgraded to mIRC 6.15 and I noticed some of my aliases made mIRC hang. I tracked it down to be a problem with non breaking spaces (the $chr(160) bug).

I tried a find/repalce in mIRC but it kept hanging on the aliases. I did a find/replace and replaced them all with normal spaces in an external editor.

Now every time I try and use a multiline alias I get this error message as many times as there are lines in the alias:

Code:
.----'-/'-/ Unknown command


(The reason I used none breaking spaces is because because mIRC tends (tended?) to collapse a sequence of spaces to one space after a /say in an alias so that screwed up ascii art and such.)

EDIT: I have been misguided by being focused on the aliases. The problem occurs for /say in any situation, be it on a channel, in a query, ... and be it typed in or aliased/scripted.

mIRC version: 6.15
date installed: 2004-06-06
OS: Windows 2000 Pro
hardware: Intel PII 450 MHz / 512 MB ram
connection: ADSL 3.3 Mbit down 128 kbit up
Posted By: turboke

.----'-/'-/ Unknown command - 06/06/04 05:28 PM

I overlooked something peculiar, too: the messages isn't in the colour other "Unknown command" messages appear. It uses two colours, none of which is assigned to such an event.

Code:
[color:yellow].----'-/'[/color][color:green]-/ Unknown command[/color]


The first characthers (.----'-/') are yellow, the rest (-/ Unknown command) is green.

I also checked back in the logs, I succesfully used a /say singleline alias before I replace the non breaking spaces by normal ones, and the same alias produces the same error now.
Posted By: Iori

Re: .----'-/'-/ Unknown command - 06/06/04 08:31 PM

I think you should search for "8----'-/'3-/" (or 08----'-/'03-/) in your script files. (Maybe part of a rose ascii art?) If a script has gone awry and is sending that string, with or without anything following it, to the server, the error you will see is exactly what you described.

Possibly the search/replace somehow removed a line break.
Posted By: turboke

Re: .----'-/'-/ Unknown command - 06/06/04 08:56 PM

Those lines seem to cause it:

Code:
say 08.----'-/'03-/        04':::::::::::::'        04\-09'\-'----.
say  08'-..-|07^08/           04':::::::::'           09\07,09|-..-'`
say       08/\/\             04':::::'             09/\/\
say       08'--               04':'               09`--'


They are contained within the { } of a multiline alias. However for some reason (as you can see) the colours aren't "closed" at the end of the lines. Probably my mistake, I closed them in all other aliases. Since the line preceding the first one shown ends in a } that way, mIRC considers the alias as closed, interprets these as new aliases and ignores the real final }. The preceding line is:

Code:
say      08{ \/'15o08;07====-  04:::::::.:::::::  07-====09;15o09'\/ }


I checked a backup of my aliases and it's always been that way, so either up until 6.14 mIRC didn't consider a } as closing a block until it's on its own line, or it no longer recognizes the } as closing the { in the beginning of the line. I haven't found anything about it in versions.txt, I suggest it get added with the correct explanation (and probably also in the help file so future scripters can take this behaviour into account). Anyway, closing the colours fixed the problem.

Instead of searching for the string, I just looked in the Alias menu under "s" and saw "say" listed for times. But it was your reply that gave me this idea, so thanks.
Posted By: Kelder

Re: .----'-/'-/ Unknown command - 06/06/04 09:24 PM

I have no idea what you mean by "closing" colors, the mIRC scripting language treats those ctrl-k's just like other text.

However, { and } are only recognized when they are surrounded by spaces, and that's the case with the last one (and not the first one). So, either put 2 ctrl-b codes right before it or use $chr(125) instead

(edit: typo, tx Iori)
Posted By: turboke

Re: .----'-/'-/ Unknown command - 06/06/04 09:45 PM

By "closing" I mean putting a Ctrl+K at the end of the line (what you'd otherwise do to restore normal colours). It's like you "open" and "close" Ctrl+B, Ctrl+U and Ctrl+R. I see them as "tags" in my mind, and tags are opened and closed again...

And anyway, it definitely is something that didn't happen before 6.15.
Posted By: zaz

Re: .----'-/'-/ Unknown command - 07/06/04 04:35 AM

Try replacing /say with /msg $active.

You can terminate ALL control codes at the end of the line with a single Ctrl+O
© 2019 mIRC Discussion Forums