mIRC Homepage

[solved] Sending, err... nothing (0x00)

Posted By: weissbrot

[solved] Sending, err... nothing (0x00) - 29/07/07 12:14 PM

I'm trying to query a gameserver. To do this i need to send 10 bytes per UDP which is simple enough. The problem is the querystring itself:

0xFE,0xFD,0x00,0x04,0x05,0x06,0x07,0xFF,0xFF,0xFF

I have no problem with 9 of these bytes, i can simply send them as plain text. But i cannot find a way to send the 0x00 byte.

Is there any way to make this happen? I can't find a workaround...


[Edit]Okay, i solved the problem by storing the query in a file.
Code:
bread arma.bin 0 10 &query
sockudp -k arma $arma.port $arma.ip $arma.port &query


Posted By: Bekar

Re: [solved] Sending, err... nothing (0x00) - 29/07/07 08:54 PM

Just wondering, why didn't the following work:

Code:
bset &query 1 254 253 0 4 5 6 7 255 255 255
sockudp -k arma $arma.port $arma.ip $arma.port &query

This should set the binary variable &query and make it available for use for the following command.

The thing to note about binary variables is that they are temporary variables. As soon as the routine that uses them is done, they are unset (similar to a /var or '/set -u0').
© 2022 mIRC Discussion Forums