mIRC Homepage

Assistance required... Reply within!

Posted By: BritishGent

Assistance required... Reply within! - 26/04/07 11:29 PM

Hi there good folks of mIRC smile

I have a small issue I need help resolving.....

I have this bot i use to control my chat room and upto a few days ago i could remotely change the nick by typing:
!nick <new nick>
But for some reason I can not see it now does not seem to work frown
I have enclosed the script that worked, I add that this has not been altered at any time since it worked......
Code:
on 500:Text:nick*:?: {
if ($2 == $null) { .msg $nick Command incomplete. Syntax: /msg $me nick <nickname to use>. | halt }
if ($2 !== $null) { 
  if ($2 === $me) { .msg $nick I already have that nick. | halt }
  else { //nick $2 | .msg $nick Nickname change attempt completed. }
}
}

the 500 is the number assigned to the bot owner just incase anyone is unsure.
Any help on this matter would be appreciated.

Thank you in advance smile
Posted By: Riamus2

Re: Assistance required... Reply within! - 26/04/07 11:57 PM

Well, if you're doing the command, you need to be 500+. Also, the script is set to use:

nick newnick

Not:

!nick newnick

And it will only work in PM.
Posted By: Solo1

Re: Assistance required... Reply within! - 27/04/07 12:40 PM

I cant see how that script ever worked. maybe use the following.

Code:
on 500:text:!nick*:?: {
  if (!$2) || ($2 === $me) { .msg $nick $iif($ifmatch == $me,i already have that nick,Syntax: /msg $me nick <nickname to use>.) | return }
  nick $2 | .msg $nick Nick change completed.
}
Posted By: BritishGent

Re: Assistance required... Reply within! - 28/04/07 03:02 PM

Neither of those responses seemed to cure the problem but thanks guy's i'll keep on it as i know it worked up till my last re-install so it has to be something i am missing.
© 2022 mIRC Discussion Forums