mIRC Homepage

turn off ctcpreply time

Posted By: javatis

turn off ctcpreply time - 13/07/05 10:25 PM

i have a lil problem

iam using a script as base that works fine but it replys on time with us time instead of german time... i deleted everything into the remote files with ctcpreply $nick TIME also turned off the "listen" to ctcp under remote , users, variables....

but it still replys..


can someone tell what i have to searc for.. i searched each file in each subfolder

pls help
Posted By: xMIRCd

Re: turn off ctcpreply time - 13/07/05 11:47 PM

You don't need to turn it off! Just use this script.

ctcp *:TIME:*:{
ctcpreply $nick TIME $asctime(hh:nn:ss)
halt
}
Posted By: javatis

Re: turn off ctcpreply time - 14/07/05 07:21 AM

hey ... than i have 2 local times:D an english and an german one!!

but i only whant to responde once!


Greetz
Posted By: Riamus2

Re: turn off ctcpreply time - 14/07/05 12:38 PM

Try this:

Code:
ctcp ^*:TIME:*:{
  ctcpreply $nick TIME $asctime(hh:nn:ss)
  haltdef
} 


Note that I haven't tested it.
Posted By: javatis

Re: turn off ctcpreply time - 14/07/05 02:01 PM

thisone also replys 2 times english one and time only ...

well may i find it in files the english ctcprply is (for example):

Thu Jul 14 15:57:54 2005

so what would be the script code for that ???

ddd mmm dd $time yyyy

^^ that^^ (was not fund in any of the files)

greetzs
Posted By: MikeChat

Re: turn off ctcpreply time - 14/07/05 02:45 PM

the format of $fulldate is what you posted:
Thu Jul 14 07:37:05 2005

You could also do:
Code:
//say $asctime(ddd mmm dd hh:nn:ss yyyy)

//say $asctime(mm/dd/yy hh:nn:ss) returns 07/14/05 07:41:10

//say $asctime(dddd) the $ord($asctime(d)) of $asctime(mmmm) at $asctime(h:nn TT)
returns Thursday the 14th of July at 7:43 AM


does this help?
Posted By: MikeChat

Re: turn off ctcpreply time - 14/07/05 03:13 PM

from mIRC help files:
Quote:

Changing a standard CTCP reply

ctcp 1:ping:?:/notice $nick Ouch! | /halt

This will react to the standard ping CTCP and will reply with "Ouch!". The /halt at the end of the line prevents the standard ping reply from being sent. If you don't use the /halt, the standard reply to PING will be sent.

ctcp 1:time:?:/notice $nick The time here is around $time | /halt

This will react to the standard time CTCP and will reply with the above message. Again, the /halt prevents the standard time reply from being sent.

so try
Code:
ctcp *:time:?:{
notice $nick $asctime(mm/dd/yy hh:mm TT)
halt
}
Posted By: javatis

Re: turn off ctcpreply time - 14/07/05 05:54 PM

lol i found it i searched all files in the mirc script folder for $fulldate foundet 2 rows and deleted them laugh

greeeeeetzzzz

and thx very much
© 2022 mIRC Discussion Forums