mIRC Homepage

Remote script problems.

Posted By: CuBiC

Remote script problems. - 11/12/02 09:04 AM

I've been trying to learn scripting lately, but one problem is stopping me. My computer won't let any of my mIRC's run remote scripts somehow. All remote is on. Other's have tried copying my script into their mIRC and it works for them. What can be the problem?
Posted By: Cobra

Re: Remote script problems. - 11/12/02 09:20 AM

many things can cause scripts not to work.

one being { } issues above the location of the remote, anouther could be 2 or more of the same type of event (ie having 2 on *:TEXT:*:#: { } events

along wiht a few other things

as a test, copy the mirc.exe program file to a new folder by itself, and run it, then from there load the file your trying to get to work and see if it does

if it does then you will know that the problem is the current script(s) you have loaded are conflicting with one anouther in some fasion.

common fixes for this is to click in the script editor file > order .. and place the new script to the top of the list, or if your adding remotes to an existing file, place the new remotes at the top of that file (however it could then make other things below it not work)

if these sugestions havent helped let us know what happened when you tryed them and we will go from there, but i'm beting its a script conflict problem.

Cobra^
Posted By: CuBiC

Re: Remote script problems. - 11/12/02 09:27 AM

Sorry. I forgot to tell you. I have tried in a freshly installed mIRC too. By putting only one line of code in the remote script ini.
Posted By: Cobra

Re: Remote script problems. - 11/12/02 09:36 AM

k, just to varify then,

1. /remote on
displays this correct: * Remote is on (Ctcps,Events,Raw) ?

2. //echo -a * $script(0)
displays: 1

3. In your script file (view by pressing ALT+R) you only have 1 remote ?

if all the above are true, and that remote does not work for you, paste the remote so we can see it please.

i can think of no reason why your remotes simply wouldnt work if they were turned on and there were no conflicts. but lets see what the remote is trying to do that you have loaded :P

also u might try testing with a different remove, clear out the one you have and simply put this as a test:

on *:INPUT:*: { echo -a * you typed this: $1- }

and see if when you type you receive that echo or not.

Cobra^
Posted By: CuBiC

Re: Remote script problems. - 11/12/02 10:15 AM

hmm.
Your test works. Seems that I have problems with on 1:TEXT.
on 1:TEXT:test:#:/msg $chan It works
That is my test remote. It won't work.
Posted By: Aubs

Re: Remote script problems. - 11/12/02 02:29 PM

Try using this:

on *:TEXT:*test*:#:{ /msg $chan Thanks $nick $+ , It works }

then get someone else (you can't get this event to activate when you say something in a channel) to say something with the word test in it (EG: "This is to test your script")

Hope it helps you wink
Posted By: Cobra

Re: Remote script problems. - 11/12/02 05:43 PM

ok at least now we know that your remotes are working properly smile

next step

First, relaize that the on text event is made to triger when someone else sends text to your query or a channel your on (int his case a channel your in because you specified a '#' )

so do not expect the remote to triger when you type, only when other do.

next i would check your user levelsyou may have a non numerc user level added, in which case mIRC would not triger an event defined for user level 1 if the user level of $nick is non numeric

you can either go in and clear your user levles or simply change the 1 to a * (although i recomend clearing your user levels and leaving it a 1 )

also realize as the person who replyed to you before me pointed out, it will only triger when they say 'test' .. nothing else .. so it will not triger for 'this is a test'

i usualy recomend to users that you place a * in the matchtext field and do anything more u wish to do there in if then else statments .. combine on text events into a single event

Code:
on 1:TEXT:*:#: {
  if (test isin $1-) { msg $chan $nick said test! }
}


give it a try,

Cobra^
Posted By: CuBiC

Re: Remote script problems. - 11/12/02 07:38 PM

I reinstalled mIRC and now it works. thanx anyway
when i put {} in my remote the lines after that won't work. what can that mean??
Posted By: FunChatter

Re: Remote script problems. - 11/12/02 08:00 PM

you type the "test" or someone else types it?
Posted By: Cobra

Re: Remote script problems. - 11/12/02 10:22 PM

ok first realize that these are not problems with mirc

these are problems with your scripting

on 1:EVENT: { code }

make sure the { } 's have spaces on each side of them
if you still cant get it to work paste the non working code here and we will take a look at it

Cobra^
Posted By: CuBiC

Re: Remote script problems. - 11/12/02 11:25 PM

bah. forgot spaces.
© 2019 mIRC Discussion Forums