mIRC Homepage

SSL connection error

Posted By: tweek

SSL connection error - 06/12/19 06:59 AM

I use UICN server from the server list. They offer SSL at +9999 port. Myself and others have tried to join this but keep getting wrong SSL version error message. I can join without SSL just fine. I have asked them about this a few times in their help channel but never get anyone to respond. I am long time user of mirc but sometimes stuff just confuses me. Maybe someone with more technical knowledge can look and see what can be done to remedy this. That is if anything can be done on your end at all. I wasn't sure if there was a version of SSL that was backwards compatible or what with this issue. Or what the issue was or how to fix it. I have the lastest version of mirc and Windows 10 all up to date. Thanks guys! Love all your work!
Posted By: KindOne

Re: SSL connection error - 06/12/19 09:10 AM

Looks like UICN is doing something wrong on their side (missing cert files?). I've tried sslv2, sslv3, tls1, tls1.1 tls1.2, and tls1.3, I basically get the same error.

kindone@laptop:~$ openssl s_client -connect irc.uicn.net:9999
139745690408064:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:../ssl/record/ssl3_record.c:332:
no peer certificate available
No client certificate CA names sent
SSL handshake has read 5 bytes and written 304 bytes
Verification: OK
New, (NONE), Cipher is (NONE)
Secure Renegotiation IS NOT supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
Early data was not sent
Verify return code: 0 (ok)

Posted By: tweek

Re: SSL connection error - 07/12/19 11:16 AM

Thanks for looking into this for me. I have asked them several times about this but never get an answer. Guess I just wont worry about it there.
© 2020 mIRC Discussion Forums