mIRC Homepage
Posted By: NrWarren SSL connection drops out at raw event 005 - 24/02/16 05:37 AM
hello, im having trouble connecting to an SSL irc server.

I am using windows 7, with mIRC 7.43

I can connect to the server fine without SSL, but when I
try to connect with SSL. I receive the SSL certificate
dialog, and confirm it.

It then proceeds to send the typical raw events you'd
normally expect, but stops at the very last raw event 005.

Which is the part of the event that has the SSL=ip:port
(where ip/port is the servers real ip and port)

It just stops on that line, and refuses to go any further.
until it eventually disconnects with:
* [10101] Host disconnected

Also, reconnecting indicates that the nickname is in use,
so im assuming that i'm connected to the server, but its
just not relaying it via the SSL, and probably disconnects
due to the client not seeing a ping request.

Other people appear to be able to connect to the server
fine. anyone have any ideas on what this might be?

Is there any particular windows services or network
protocols that might be disabled that might be involved?

I don't think its a firewall/router issue, as i've
tried it with them disabled as well.

I also thought that... maybe the SSL certificate had a
hostname that couldn't be resolved to the IP listed in
the SSL=ip:port. Which is why it was dropping off there,
so I went to c:\windows\system32\drivers\etc\hosts and
put in a manual translation for host -> ip
and that didn't seem to resolve it either.

anyone got any ideas?
i am also in contact with the owner of the server,
he doesn't have any idea whats causing it. So if there's
anything i need to relay to them, that's an option.

thank you.
Posted By: Khaled Re: SSL connection drops out at raw event 005 - 24/02/16 11:39 AM
mIRC does not parse the SSL=ip:port token in numeric 005, so that is unlikely to be the cause of the issue.

If you install a new copy of mIRC in your Windows Documents folder, using the "Portable" option in the installer, and then try to use that copy of mIRC to connect to the server, do you see the same issue?
i see.

no that didn't work either, disconnects at the same place.

I can also connect to other SSL servers fine on the same
well i think i can safely rule out that its mIRC related
or even ircd related.

i tried connecting through a VPN, and it connects perfectly
fine. The same server also hosts a radio that has the same
connection issue, only works through a VPN, where months
prior both were working.

it completely won't connect with the European server, and
drops out when connecting to the Canadian server.

only thing i can think of is...

a. driver related.
b. website hosting blocking my ip range.
c. router physically broken.
d. little green men. sick

Either way, I'm not sure if you can be much more assistance
unless anyone has any idea how i could narrow this down?

I've factory rebooted my router, reset all defaults,
turned off the NAT, turned off the Router Firewall,
turned off software firewall.

not entirely sure what else is left, besides reinstalling
okay, problem solved.

I connected my router to another computer and figured
out it wasn't my router or the server.

then I realized that since the VPN was using a different
network adapter to connect, that maybe it was my network
adapter causing the problem.

Resetting the services didn't seem to matter.

So since reinstalling the network adapter didn't work,
I installed a NIC card, and that works fine.

So I'm going to file this issue as a possible corruption
of my network adapter and or the infrastructure connected
to it.

Thanks for your help khaled!
upon closer examination.

i've narrowed it back to the router.

i didn't suspect it was the router because it
connected fine from another computer.

it turns out, when it connected to the other computer
the router created a new empty "application" firewall profile.

there was a secondary global firewall in place though
that was allowing it.

the application firewall for my first computer had the
SSL port forwarded though. Which ordinarily, should have
allowed it through... its not until I remove the
application firewall rule, that the secondary firewall
allows it to 'fully' connect.

i've noticed the router has been taking increasingly longer
to synchronize its 'power' status, so this might be a good
indicator its ready to check out. (ie expire)

so... mystery solved.
© mIRC Discussion Forums