mIRC Homepage

SSL

Posted By: alchemy

SSL - 30/06/08 08:04 AM

Any idea on how to get SSL working for mIRC on XP64?

I was told to place the DLL's in the SysWOW64 directory, which didn't seem to work. It doesn't work when I place them in system32, or in the mIRC directories either.


Any ideas or suggestions that could get this working?

Many thanks.
Posted By: argv0

Re: SSL - 01/07/08 12:10 AM

Download openssl from http://www.openssl.org/related/binaries.html and use the installer. It may be necessary to use 32bit dlls because mIRC is not a 64bit application. Of course, I may be wrong and the opposite may be true.
Posted By: alchemy

Re: SSL - 01/07/08 03:48 AM

Originally Posted By: argv0
Download openssl from http://www.openssl.org/related/binaries.html and use the installer. It may be necessary to use 32bit dlls because mIRC is not a 64bit application. Of course, I may be wrong and the opposite may be true.


That's actually the first thing I tried, mirc still returns false for $sslready
Posted By: argv0

Re: SSL - 01/07/08 05:15 AM

Which part of that multi-part suggestion did you try, exactly?
Posted By: alchemy

Re: SSL - 01/07/08 05:31 AM

Originally Posted By: argv0
Which part of that multi-part suggestion did you try, exactly?


Well, OpenSSL only provides 32bit DLL's anyway, so they're the ones I initially tried. I then obtained a copy for x64, and mIRC still doesnt register itself as SSL ready.

So I'm kind of stumped from here. 32bit/64bit, tried multiple directories, I'm about to give up hope regarding mIRC/SSL/x64
Posted By: argv0

Re: SSL - 01/07/08 06:04 AM

Have you ever gotten it in x32?
Posted By: alchemy

Re: SSL - 01/07/08 06:59 AM

Originally Posted By: argv0
Have you ever gotten it in x32?


Yes, SSL worked fine with mIRC when I was running x32
Posted By: argv0

Re: SSL - 01/07/08 07:05 PM

Use 0.9.8g, mIRC doesn't support OpenSSL 0.9.8h
Posted By: alchemy

Re: SSL - 02/07/08 12:24 AM

Originally Posted By: argv0
Use 0.9.8g, mIRC doesn't support OpenSSL 0.9.8h


Doesn't work with 0.9.8h, or 0.9.8g
Posted By: alchemy

Re: SSL - 02/07/08 12:37 AM

Problem has been solved..

libeay32.dll and ssleay32.dll need to be placed in SysWOW64 alongside with MSVCR70d.dll
Posted By: P4k3

Re: SSL - 13/07/08 12:34 PM

Where did you find MSVCR70d.dll?
Posted By: argv0

Re: SSL - 13/07/08 06:35 PM

It's installed by the Microsoft Visual C++ 2005 Redistributable Package (x86)
Posted By: DLS

Re: SSL - 19/07/08 02:47 AM

OMG you rule!

I've been fighting w/ a latest mirc + latest openssl problem lately.

mIRC wasn't able to locate SSL libraries even tho both .dll files were in /system32/ AND in /mirc/. In the end i had been running the latest installs (mIRC v6.32 & v6.33 and OpenSSL v0.9.8h) without any success.

After trying your trick, downgrade OpenSSL, it worked like a charm!

I'm running XP PRO 32 bits, fresh install btw.

Even tho pretty insignificant to some, your advise did the whole difference, thanks again!

a proud mIRC user.
Posted By: DLS

Re: SSL - 19/07/08 02:48 AM

(argv0)
© 2022 mIRC Discussion Forums