mIRC Homepage

Lagging

Posted By: Poppy

Lagging - 06/06/04 01:50 PM

For the last couple of days, every time I connect to irc, my lag meter just keeps going up and up, to the point where it reaches over 200 seconds. I try to close mIRC, but it just freezes - I have to ctrl+alt+del to end it, and even then it sometimes doesn't work. If I don't have mIRC open, I can stay connected to the internet indefinitely - but as soon as I open mIRC this happens. I haven't got a clue as to why this should suddenly happen - I upgraded to 6.15 and it happened for the first time then, so I went back to 6.14 and it's still doing it. I use mIRC with Peace and Protection, same as I have for a couple of years now and never had this problem before. It's not the server either, as it's only happening to me. Any ideas or suggestions much appreciated!
Posted By: Marantz

Re: Lagging - 06/06/04 01:56 PM

Try and open a debug window up /debug @debug
and see if your script is sending lots of commands out
or perhaps /timers
sounds more of a script issue
Posted By: Mentality

Re: Lagging - 06/06/04 01:57 PM

Do you actually disconnect from the Internet? The lag bar will increase if you have Remotes turned off due to the fact it's not checking your ping reply and so it just assumes you're not replying. Make sure Remotes are on.

On the other hand, try /remote off and see if it is a script causing the issue. Try installing a fresh mIRC. If you've installed other scripts with PnP you might try unloading them as PnP is known not to be too compatible with 3rd party addons.

Does this happen with every network you try? Do you disconnect from any exterior programs such as MSN Messenger, AIM, ICQ etc.?

Good to see you posting again btw wink

Regards,
Posted By: Poppy

Re: Lagging - 06/06/04 02:03 PM

lol thanks, I have a habit of turning up like a bad penny :tongue:
I've tried /remote on and /remote off - no difference. I don't use any other scripts or addons. I'm still connected to the net when this happens, but I can't close mIRC without doing a ctrl+alt+del - it just completely freezes up. The only thing I've noticed is if I disconnect from the internet, mIRC responds again and I can reconnect - but then the whole thing starts all over again. I'd try the @debug thing, but I'm so lagged it'll never happen confused
Posted By: Mentality

Re: Lagging - 06/06/04 02:21 PM

on *:connect:{
debug @debug
timers off
}

That should do it before you get lagged!

Regards,
Posted By: Poppy

Re: Lagging - 06/06/04 02:37 PM

Bah! I spoke too soon about staying connected to the net indefinitely! Weird thing just happened and I didn't even have mIRC open. The systray and taskbar completely froze up, but I could still manage to click on desktop shortcuts. Couldn't get task manager to come up either this time. Something very odd going on here and it's obviously not a mIRC issue.
Posted By: Mentality

Re: Lagging - 06/06/04 02:40 PM

Perhaps you installed something recently? Might try system restore. As usual, I suggest a virus/trojan/spyware scan, have a good spring clean of your computer. Run disk defrag, disk cleanup - give it a good ole' pampering grin

Regards,
Posted By: Poppy

Re: Lagging - 06/06/04 03:09 PM

I defragged this morning, cleared my cache, I do a daily virus scan (all definitions are up to date) plus a weekly trojan scan which didn't show anything up just now. Ran spybot yesterday - I even went to pcpitstop - apart from being very slightly low on disk space everything was fine there too. I'll try a system restore next - if it doesn't work I really can't think of anything else to do apart from reformat. crazy
Posted By: NightCrawler8283

Re: Lagging - 06/06/04 05:17 PM

check your processes. im going to assume you use win xp. just hit ctrl-del and look under processes. see what may be taking up a whole lot of cpu. if there is something and u dont recognize it then kill it and see what happens
Posted By: Poppy

Re: Lagging - 07/06/04 06:10 PM

I've managed to stay connected for almost 24 hours now, the only thing I've done differently is close Soulseek. Never had a problem with it before, but I'm just going to put it down to 'one of those things'. Thanks for all the help/suggestions. grin
© 2019 mIRC Discussion Forums