mIRC Homepage

DCC problems with ADSL router

Posted By: horsie

DCC problems with ADSL router - 08/05/04 10:54 AM

The usual problem: I can't DCC send or resume DCC gets.

Unfortunately my router's firmware settings are entirely undocumented. Not that that would help: I'm sure I've tried all that I can to allow DCC gets in IRC. (I also cannot set up a working FTP server.)

Anyway, I'm sure I've done everything I can possibly do with regard to NAT & port forwarding. (From what I've seen in this forum and elsewhere.) Since I'm pretty much at a loss I've made these screenshots of my router settings in the hope that there's something more subtle that might register with an expert.

(Who knows - maybe it's a bug with my router? The firmware update link doesn't work either!)

Btw, everything else is working for me: web browsing, etc,... even P2P sharing (u/ling - sometimes, at least - as well as d/ling)

http://homepages.ihug.co.nz/~ghawkins/01-wan-a.gif
http://homepages.ihug.co.nz/~ghawkins/02-wan-b.gif
http://homepages.ihug.co.nz/~ghawkins/03-lan.gif
http://homepages.ihug.co.nz/~ghawkins/04-ppp.gif
http://homepages.ihug.co.nz/~ghawkins/05-nat.gif
http://homepages.ihug.co.nz/~ghawkins/06-portforward.gif
http://homepages.ihug.co.nz/~ghawkins/07-miscconfig.gif

Incidentally, although the above settings don't reflect it, I have also tried a DMZ for my computer at IP 10.0.0.3. That didn't work either.

Btw, my modem/router is a Lectron AR800C2-A (http://www.lectron.com.tw/ar800c2.html)
The firmware (see screenshots) is apparently from Conexant.

Btw, I'm fairly sure my mIRC settings are what they should be. But I *could* be missing something there also... I don't understand the 'Bind sockets to IP address' option, for example.

Thanks for any help. It will be much appreciated.
Posted By: Skip

Re: DCC problems with ADSL router - 08/05/04 11:35 AM

Do you have any luck changing "Dynamic NAPT" (in 05-nat.gif) to just regular NAT or NAPT? I'm not exactly sure how NAPT is different to NAT (information I searched for was sketchy), or what makes dynamic NAPT 'dynamic'. I'm sure you were expecting a slightly more technical reply than 'just play with it'.

Good luck smile
Posted By: horsie

Re: DCC problems with ADSL router - 10/05/04 11:56 AM

Nope, no luck trying that.

As far as I can tell NAPT is for when more than one computer is connected to the router. But I could be wrong.

I think I need expert help. That's what I'm hoping for here. smile I think I need to get back to the computer shop and ask if they know of problems with this model....

Or if they know how to update the firmware. The link from the router's browser settings doesn't work.
Posted By: horsie

Re: DCC problems with ADSL router - 14/05/04 02:55 AM

I have some more information about the problem with not being able to DCC send.

The curious thing is that when I attempt to send a file the recipient's mIRC says that it has been sent, even though it is still trying to connect.

Eventually it timeouts and says 'DCC send to Blah incomplete (connection failed)'. Yet despite this the recipient thinks it has been received! What's with that?
Posted By: horsie

Re: DCC problems with ADSL router - 14/05/04 03:22 AM

P.S. In setting up port forwarding for DCC sends do I set them to TCP or UDP? I've been assuming TCP.
Posted By: teohhanhui

Re: DCC problems with ADSL router - 10/03/06 01:40 PM

My ADSL router is also using Conexant chipset.

Unfortunately I have the same problem and have yet to find a working solution.

Discussions of this problem has been underway for years, but still I cannot find a working solution for this.

Some suggested though that I change the default port to that other than 6667. However, that's completely useless in my case.

I really must get resume to work!!! Please, someone do help us on this...

May I know if this problem is specific to Conexant-based routers?
© 2022 mIRC Discussion Forums