mIRC Homepage
Posted By: painkiller_87 connection refused problem here - 01/01/04 10:39 PM
i have checked the settings on my US Rootics 9003 ADSL modem... my US Robotics 8054 wireless router... and the network settings...

all my NAT Gateways and my firewalls are disabled then why is it refusing the connection?

i have checked the server the port and all of that and its perfect.

i get the same error for all the servers i try to connect...
if it helps my ISP is Etisalat in United Arab Emirates...

help will be much appreciated...

Posted By: Mentality Re: connection refused problem here - 02/01/04 03:04 PM
If you disconnect the router temporarily, and then try to connect, you'll know for definite if it's the router or not. This just clears this possibility out of the way to make it clear for all of us.

Make sure your ISP hasn't got you firewalled - the only way to do this is to phone them up and ask, many of the ISP's that DO firewall their customers don't tell them beforehand.

Check if you have any conflicting Firewalls that might be affecting or clashing with the router. If you have Windows XP, check out these instructions on how to disable it.

Finally, there have been many issues covering this error message, so perhaps you'd like to run a Search on it and see if any answers turn up. For best results, expand to 'All Forums' and 'All Posts'.

I hope you get it sorted soon smile

Posted By: painkiller_87 Re: connection refused problem here - 03/01/04 03:19 PM
I have checked with my ISP, they havent blocked the port, they dont have any firewalls.

I have tried the links u gave above and i ahve done a search...

i tried the /server -m (server here)

thingy which i found on one of the threads and it still refused the connection.

this seems quite wierd as i have surely disabled all the firewalls which i possibly can...

any more suggestions?
Posted By: PastMaster Re: connection refused problem here - 03/01/04 04:34 PM
It is enitirely possible that the connection is refused because the server/network to which your are trying to connect just doesn't recognise/accept the IP range used by your ISP.

This could be oversight, or because the ISP has new IP ranges, or simply because a lot of insecure/abusive connections have been noted from that IP range in the past.

Try writing to the server admins asking (politely!) why you are unable to connect, and - if one of the first 2 possible reasons is true - whether it would be possible to rectify the situation.


Posted By: painkiller_87 Re: connection refused problem here - 03/01/04 05:41 PM
the thing is... i have used irc before... the problem only occured after i got the new ADSL modem and after installed the wireless router and setup the wireless network.

trust me i have tried to connect to all sorts of different servers... i get the same problem for all the servers. i am fairly sure it is my computer...

can someone give me a server with a lower port... something a bit less then 6667... high end ports maybe blocked... my ISP is very incompetent and wont give me info which i want...

yes i can change my service but i cant coz its a monopoly...
Posted By: ParaBrat Re: connection refused problem here - 03/01/04 10:14 PM
have you tried connecting to the ip instead of the domain, like /server

one i know you can use 6660 is /server jade.dal.net 6660
Posted By: PastMaster Re: connection refused problem here - 04/01/04 09:27 AM
If you have just moved to ADSL from dialup or ISDN, that would mean that you have moved from using a dynamic IP to using a new static IP in a new IP range - which to me would imply that the problem is simply that this new IP block is not yet widely recognised, i.e. hasn't yet made it into the server I-lines.

If the problem was with your computer I think you would be getting different error messages - like "unable to connect", or being disconnected for having no identd. etc.

"Connection refused" means, iirc, that you have successfully contacted the server, but that it isn't interested in you.

Posted By: painkiller_87 Re: connection refused problem here - 04/01/04 11:34 AM
ok... it seems that it connects to all ports except 6667... one reason for this to happen maybe that i have made a mistake in configuring my router or my modem. is there any other possible reason why it wont let me connect to port 6667?

it may be my ISP... to whom i am gonig to have a chat with soon

any other reasons?
Posted By: Mentality Re: connection refused problem here - 04/01/04 11:53 AM
The ones you mentioned are more likely, but it's also possible that the server does not accept connections from port 6667. However, if you're connecting to one of the bigger networks, such as quakenet/dalnet/undernet/efnet/gamesnet etc etc this is extremely unlikely. 6667 is a widely used port for server connections and 99% of public servers will support it.

Posted By: painkiller_87 Re: connection refused problem here - 04/01/04 11:59 AM
dalnet, efnet and all thos big ones on 6667, i cannot connect to...

i just called my ISP and they say that 6667 is not blocked...

so i dont think its possible that the so many servers on 6667 blocks me off. it is very unlikely.

i have tried atleast 20 different servers on 6667 and all gave the ame error... i have also asked the server admin to check if my IP address is refused... i am waiting on a reply from him/her.

i am going to see what US Robotics has to say bout this.
Posted By: painkiller_87 Re: connection refused problem here - 04/01/04 04:44 PM
i have tried something else...

i have connected my internet directly to my comp and then internet shared as opposed to adsl modem to router and router to both the comps...

now i am getting connection time out on port 6667 but i can still connect to other ports...

get even more bizarre eh?

dont we all just love computers???

© mIRC Discussion Forums