mIRC Homepage

Find & Search Not working

Posted By: aussie1855

Find & Search Not working - 13/10/19 12:01 PM

Since this latest update i.e. 7.57 I can't @search or @find to response to the request.

Has the command changed or am i doing something wrong?

Many thanks

Michael
Posted By: maroon

Re: Find & Search Not working - 13/10/19 03:48 PM

Your question is not clear. There is no command in mIRC which begins with "@", so either you have a script with aliases of those 2 names, or this is a script which responds to a sentence beginning with either of those 2 words. Is this search/response going on between 2 different nicks where their script makes a @find response to your @search, or is your own script supposed to respond with @find to your own @search?

The only non-scripting reasons I can think of for your problem is:
1. your scripts have been disabled. if "/remote" says 'off', you can turn your event handing back on with: /remote on
2. when upgrading, if you installed the new version into a different folder, or answered the install question that you did not want to keep existing settings, one of those existing settings is to know which scripts to load.

If #2 happened, then the REMOTE tab of the scripts editor is blank, and so is the list of scripts shown in the "view" menu of that window. Your scripts shouldn't be deleted, you just need to find where they are and install them again.
3. You've installed a new script which is able to intercept and block the old behavior
4. When either of these commands fail to do anything, is there also an error message displayed in the Status Window? If there is, that can give a clue to the problem: /window -a Status Window
Posted By: TechChaos

Re: Find & Search Not working - 26/11/19 06:21 AM

@search or @find are commands for a script called Omenserve. There seems to be a problem with mIRC v7.58 not sending the results from Omenserve, to the nick who issued the command. Try using an older version of mIRC. Omenserve, hasn't had a new version in years now...
Posted By: maroon

Re: Find & Search Not working - 26/11/19 07:29 PM

Or, try finding out exactly what the problem is, rather than advising an older mirc version. If a script is not behaving the same, it might simply be a scripting error that is no longer forgiven. Also, sometimes scripts written very long ago are using DLL's to provide functionality which has been added to more recent mirc versions, and the script could be re-coded to use the built-in function in place of the DLL. In rare cases the problem can be due to a new identifier having the same name as a handmade alias. For example, if someone had written a ZIP identifier, then suddenly the newer versions start using the new $zip identifier instead of the old alias. In that case, you could either modify the script to work with the new identifier, or simply rename your identifier and references to it.
Posted By: TechChaos

Re: Find & Search Not working - 28/11/19 06:35 AM

Didn't mean it quite like that. I meant to say to stick with the older version until someone figures out why Omenserve, broke and how to fix the problem. I am noticing alot of scripts aren't working with v7.58. So it's not just Omenserve. I have check all your recommendations above and all check out fine. We get no error messages from Omenserve.
Posted By: TechChaos

Re: Find & Search Not working - 28/11/19 06:59 AM

This was an upgrade of mIRC only. All scripts was already in use prior to upgrading mIRC. /Remotes are on, Remote isn't blank.
© 2020 mIRC Discussion Forums