mIRC Home    About    Download    Register    News    Help

Print Thread
Winamp #93788 12/08/04 11:21 AM
Joined: Aug 2004
Posts: 1
3
3vil Offline OP
Mostly harmless
OP Offline
Mostly harmless
3
Joined: Aug 2004
Posts: 1
Somone was going to help me on this but he never im me back so I move on to the next idea knowing full well that this is a little to complicated for me im try to do the basic script for playing Winplay music this is what I have so far
alias winplay {
var %windir = C:\Program Files\WinAmp\

if (!%win.comreg) {
comreg $+(",%windir,Plugins\gen_scripting.dll")
set %win.comreg 1
}
if ($com(winamp)) { .comclose winamp }

.comopen winamp gen_scripting.WinAmp

if ($com(winamp, GetVersion, 1) != 1) {
echo 2 -a * /winplay: Winamp is not running
comclose winamp
return
}

var %i = $com(WinAmp, GetPlaylistPosition, 2)
var %i = $com(WinAmp, GetPlaylistFile, 2, i4, $com(winamp).result)
ame is playing; $nopath($com(WinAmp).result)

.comclose winamp
....all this does is say "Evil_Is_forever is playing;" now he had said something about my programs which are 6.16 Mirc, Windows ME, and Winamp 5.04 If anyone could help plz do and even if you could just teach me how to do it Im not opposed to that either thanx


When the Gorillas attack from outer space dont come running to me......
Re: Winamp #93789 12/08/04 12:04 PM
Joined: Dec 2002
Posts: 788
C
Coolkill Offline
Hoopy frood
Offline
Hoopy frood
C
Joined: Dec 2002
Posts: 788
Well firstly, I appologise for the late reply, I have a terrible habbit of not reading my privatemsgs, here, however, the script runs fine here, using WinAmp version, 5.03 (should be fine on .04) make sure in the previous thread you did exactly what it said on how to register the dll, and it SHOULD have worked fine.

Also your missing a } at the end of the script after .comclose winamp. - My guess, a typo smile

Edit; Just downloaded 5.04, Works fine here, my guess is the dll isnt registered correctly, or isnt in the winamp plugin directory, or C:\program files\winamp isnt your default dir, if not, change the script line.

Recheck the Dll is registered with Windows,

//comreg "C:\Program Files\Winamp\Plugins\gen_scripting.dll"

Change the above file location according to your Winamp install file.

Eamonn.