mIRC Home    About    Download    Register    News    Help

Print Thread
Disconnected After Sending A Message #90708 16/07/04 03:49 PM
Joined: Jul 2004
Posts: 1
J
juke52 Offline OP
Mostly harmless
OP Offline
Mostly harmless
J
Joined: Jul 2004
Posts: 1
I'm using mIRC 6.16. After an idle period of about 10 to 15 minutes and then sending a message, I am immediately disconnected (and then reconnected, of course). This is very annoying and I have a feeling it has something to do with my network. I have 2 computers networked together using a router and they're sharing an internet connection. It has never done this WITHOUT this whole network setup so something is fishy with the network settings here causing the disconnects after messaging someone on mIRC...

Re: Disconnected After Sending A Message #90709 17/07/04 02:37 AM
Joined: Dec 2002
Posts: 349
S
Skip Offline
Fjord artisan
Offline
Fjord artisan
S
Joined: Dec 2002
Posts: 349
While I can't offer any *real* suggestions on how to stop the problem other than 'poke around' your routers configuration, try a different server/network etc, you may find setting up a timer (/timer 0 60 !pong KeepAlive) will reduce the number of disconnects (and should have your client realise it has been disconnected faster). Just put the timer setting in your perform.

Hope that helps smile

Re: Disconnected After Sending A Message #90710 18/07/04 10:12 PM
Joined: Jul 2004
Posts: 8
K
kozara Offline
Nutrimatic drinks dispenser
Offline
Nutrimatic drinks dispenser
K
Joined: Jul 2004
Posts: 8
juke52, it sounds like my Doesn't realize Cxn reset by peer until I type problem.

I also am sharing a connection with another computer via a router.

Skip, I've added your pong command on a timer to all networks perform. Hopefully that'll work a charm.

Is there any way to verify the pong is working? I have "Hide ping/pong event" off, but it's just showing the periodic ones the server initiates, not the once a minute ones I should be having.

That's the problem with the ctcp ping script I tried in the link. I couldn't tell if the script was pinging me.

Last edited by kozara; 18/07/04 10:17 PM.
Re: Disconnected After Sending A Message #90711 19/07/04 08:04 AM
Joined: Dec 2002
Posts: 349
S
Skip Offline
Fjord artisan
Offline
Fjord artisan
S
Joined: Dec 2002
Posts: 349
You could change 'pong' to 'ping', in which case you should see a 'pong from server.blah.blah: KeepAlive' every minute in your status window. This would of course get rather annoying. You can verify the pong is working by using /debug @debug and seeing if the message is sent.

Hope that helps smile

Re: Disconnected After Sending A Message #90712 20/07/04 05:17 PM
Joined: Jul 2004
Posts: 8
K
kozara Offline
Nutrimatic drinks dispenser
Offline
Nutrimatic drinks dispenser
K
Joined: Jul 2004
Posts: 8
The pongs are getting through. Thanks for telling me about the debug command. And so far, so good. Peering out is being reconnected within 60 seconds. Thank you very much!

Re: Disconnected After Sending A Message #90713 24/07/04 06:56 PM
Joined: Jul 2004
Posts: 8
K
kozara Offline
Nutrimatic drinks dispenser
Offline
Nutrimatic drinks dispenser
K
Joined: Jul 2004
Posts: 8
Still working. Thank you thank you thank you Skip!