mIRC Home    About    Download    Register    News    Help

Topic Options
#87023 - 16/06/04 03:49 AM Hear own Hightlight sounds?
P0t Offline
Pikka bird

Registered: 05/05/04
Posts: 11
Hi
Normally i only hear the sound which i set when other people highlightet me/the word
like here
on *:text:*.nice*:#: { splay nice.wav }
I only hear the sound when other people write "nice"
But i want to hear it too when i write it.
Anyone know how to do this?
Thx

Top
#87024 - 16/06/04 05:50 AM Re: Hear own Hightlight sounds?
Mentality Offline
Planetary brain

Registered: 01/06/03
Posts: 5024
Loc: London, England
In a new remote file you may use something like:

on *:input:#:{ if (*nice* iswm $1-) { splay nice.wav } }

For further help, see /help on input.

Regards,
_________________________
Mentality/Chris

Top
#87025 - 16/06/04 06:37 AM Re: Hear own Hightlight sounds?
P0t Offline
Pikka bird

Registered: 05/05/04
Posts: 11
Hi
Thx for your quick answer.I think i'm too stupid for this frown
I have to do that with some more sound files
mp3 and wav's (36 files)
And i want to write all the studff in 1 remote .mrc file
Can you give me an example?
I testet it so

on *:input:#:{ if (*.ncn* iswm $1-) { splay ncn.wav } }

}

{

on *:input:#:{ if (*.great* iswm $1-) { splay great.wav } }

}


But it doesnt work.Only the first sound works ".ncn"

What is wrong?



Top
#87026 - 16/06/04 06:46 AM Re: Hear own Hightlight sounds?
Mentality Offline
Planetary brain

Registered: 01/06/03
Posts: 5024
Loc: London, England
Probably an easier way, however, you could use elseif and something like the following:

Code:
on *:input:#:{ if (*.ncn* iswm $1-) { splay ncn.wav }
  elseif (*.great* iswm $1-) { splay great.wav }
  elseif (*.whatever* iswm $1-) { splay whatever.wav }
}


Regards,
_________________________
Mentality/Chris

Top
#87027 - 16/06/04 07:07 AM Re: Hear own Hightlight sounds?
P0t Offline
Pikka bird

Registered: 05/05/04
Posts: 11
ah that works. thx!!
But!Got one more problem frown
The sound also playes when i write ".niceNXNDSUJW"
Thats [censored],because i have files like ".nice1" and ".nice2"
And so he only playes the ".nice"
Can i write it so that the sound only playes when i only write ".nice"
sry,my englisch is not so good.but i think you understand what i mean ::P
thx for your great help!

Top
#87028 - 16/06/04 07:39 AM Re: Hear own Hightlight sounds?
Online Offline
Hoopy frood

Registered: 09/12/02
Posts: 1922
This script does exact text comparison:

On *:input:#:{
  • if (.* !iswm $1) { return }
    if ($1- == .ncn) { splay ncn.wav }
    if ($1- == .great) { splay great.wav }
    if ($1- == .nice) { splay nice.wav }
    if ($1- == .nice1) { splay nice1.wav }
    if ($1- == .nice2) { splay nice2.wav }
}

Top
#87029 - 16/06/04 01:47 PM Re: Hear own Hightlight sounds?
P0t Offline
Pikka bird

Registered: 05/05/04
Posts: 11
hmpf cry frown
thx but with this script i only hear the sounds when i write them.I want also hear them when others write them
any idea?

Top
#87030 - 16/06/04 04:40 PM Re: Hear own Hightlight sounds?
Online Offline
Hoopy frood

Registered: 09/12/02
Posts: 1922
You'll need a different event for that:

On *:text:.*:#:{
  • if ($1- == .ncn) { splay ncn.wav }
    if ($1- == .great) { splay great.wav }
    if ($1- == .nice) { splay nice.wav }
    if ($1- == .nice1) { splay nice1.wav }
    if ($1- == .nice2) { splay nice2.wav }
}

Top
#87031 - 16/06/04 07:44 PM Re: Hear own Hightlight sounds?
P0t Offline
Pikka bird

Registered: 05/05/04
Posts: 11
yea,now all works
THX for your help!

Top
#87032 - 17/06/04 01:07 AM Re: Hear own Hightlight sounds?
P0t Offline
Pikka bird

Registered: 05/05/04
Posts: 11
aaah
me againt :P
Got one more question!
I createt a popup menu like this

menu Channel,query {
.fU-SouNds
.Enable:/load -rs fUsounds.mrc
.Disable:/unload -rs fUsounds.mrc
..SouNds
..nice:/msg # .nice
}

But when i use the soundtriggers on with the popup i dont hear the sound myself!Anyone know how?

Top
#87033 - 23/10/04 09:57 PM Re: Hear own Hightlight sounds?
war59312 Offline
Mostly harmless

Registered: 23/09/04
Posts: 1
My problem is turning the darn the off. I have higlighting sounds off but still it does it. Annorying as crap.

Any help would be great.

cya,
Will

Top