mIRC Home    About    Download    Register    News    Help

Print Thread
Editbox Text #81326 30/04/04 12:52 PM
Joined: Apr 2004
Posts: 1
C
CBDallas Offline OP
Mostly harmless
OP Offline
Mostly harmless
C
Joined: Apr 2004
Posts: 1
I've noticed in mirc 6.14 there's a Really annoying "Feature" , as I'm typing if I've made a mistake I can not move backwards in the text to delete/insert a letter or space without mIRC Eating the next letter in the editbox

Example:
goodevening!
good vening!

it's a real pain.
also, in this new version of mIRC I cannot use CTRL+Del to clear the entire edit box instantly, another inconvenience.

Re: Editbox Text #81327 30/04/04 01:57 PM
Joined: Dec 2002
Posts: 1,527
L
landonsandor Offline
Hoopy frood
Offline
Hoopy frood
L
Joined: Dec 2002
Posts: 1,527
are you sure you dont have the INSERT button pressed so instead of INSERTING text it OVERWRITES text?


Those who fail history are doomed to repeat it
Re: Editbox Text #81328 30/04/04 02:05 PM
Joined: Apr 2004
Posts: 9
S
slartibartfast Offline
Nutrimatic drinks dispenser
Offline
Nutrimatic drinks dispenser
S
Joined: Apr 2004
Posts: 9
FYI:

mIRC Supports the Insert/Overwrite toggle just like most other programs on window (and linux)

The button to toggle between these modes are the Insert button.

Kinda stumped that you didn't know this. Works the same way in alot of other programs, try Wordpad.


Also as for your other "suggestion" ...

Backspace = delete char before pointer
Del = delete char after the pointer

Ctrl+Backspace = delete token before pointer
Ctrl+Del = delete token after pointer

Pretty logic... again try it in Wordpad.
Also if you want to clear the whole Editbox line just hit Down.

Re: Editbox Text #81329 02/05/04 09:52 AM
Joined: Feb 2003
Posts: 372
R
Rounin Offline
Fjord artisan
Offline
Fjord artisan
R
Joined: Feb 2003
Posts: 372
Thanks for designing Norway.

Re: Editbox Text #81330 02/05/04 06:12 PM
Joined: Feb 2003
Posts: 2,659
Raccoon Online
Hoopy frood
Online
Hoopy frood
Joined: Feb 2003
Posts: 2,659
This is also a bug in mIRC's new handling of Multibyte characters, and should be reported to the Bug Reports section of this forum (if it hasn't been already).

In the mean time, you can reverse this change to how it was in v6.12, by going to ALT+O > IRC > Messages and unchecking [ ] Multibyte editbox at the bottom. You may also uncheck all four of these options at the bottom to completely disable any special text handling.

- Raccoon


Well. At least I won lunch.
Good philosophy, see good in bad, I like!