mIRC Home    About    Download    Register    News    Help

Print Thread
Sync problem. #57200 24/10/03 01:57 PM
Joined: Mar 2003
Posts: 160
Marantz Offline OP
Vogon poet
OP Offline
Vogon poet
Joined: Mar 2003
Posts: 160
Ok, i downloaded a script to use, and kind of went through things to check for bugs so i could point them out to the author, but one i reported, he says theirs nothing wrong with the code and that it should work, if that was the case i wouldn't get an error, so i thought i'd ask on here.
any help would be appriciated.

problem:

Adresses from #blah saved in 2545463.26 seconds. 28/51 entries.

code:

raw 315:*: {
if (%ialupdate. [ $+ [ $2 ] ]) {
set -u240 %ialupdate. [ $2 ] $true
var %t = $round($calc(($ticks - $ifmatch)/1000),2)
kte_echo -s Adresses from $2 saved in %t $iif(%t == 1,second.,seconds.) $+($ialchan(*,$2,0),/,$ial(*,0)) entries.
haltdef
}
unset %m
unset %scan
haltdef
}

Re: Sync problem. #57201 24/10/03 02:14 PM
Joined: Mar 2003
Posts: 160
Marantz Offline OP
Vogon poet
OP Offline
Vogon poet
Joined: Mar 2003
Posts: 160
Adresses from #blah saved in 2545463.26 seconds. 28/51 entries.

Re: Sync problem. #57202 24/10/03 02:15 PM
Joined: Mar 2003
Posts: 160
Marantz Offline OP
Vogon poet
OP Offline
Vogon poet
Joined: Mar 2003
Posts: 160
Edited the post? :tongue:

Re: Sync problem. #57203 24/10/03 02:20 PM
Joined: Oct 2003
Posts: 273
E
EVH Offline
Fjord artisan
Offline
Fjord artisan
E
Joined: Oct 2003
Posts: 273
Yes ... sorry about that lol
It looks to me like he is setting %ialupdate.#blah
to $ctime, and then in the raw 315, he's using $ticks

Try this in command line
//set %ialupdate.#blah $ticks | who #blah

That worked for me .. if so for you too .. find where
he is setting that variable and change it to $ticks

Edit: Also changed a couple of lines in
that raw to show seconds or milliseconds.

Code:
raw 315:*: {
  if (%ialupdate. [ $+ [ $2 ] ]) {
    set -u240 %ialupdate. [ $2 ] $true
    var %t = $round($calc(($ticks - $ifmatch) / 1000),2) [color:red]$iif($calc($ticks - $ifmatch) < 1000,milliseconds.,seconds.)[/color]
    kte.echo -s Adresses from $2 saved in [color:red]%t[/color] $+($ialchan(*,$2,0),/,$ial(*,0)) entries.
    haltdef
  }
  unset %m %scan
  haltdef
}

Last edited by EVH; 24/10/03 03:06 PM.
Re: Sync problem. #57204 24/10/03 02:36 PM
Joined: Mar 2003
Posts: 160
Marantz Offline OP
Vogon poet
OP Offline
Vogon poet
Joined: Mar 2003
Posts: 160
lol nice one thanks, he'll probably give me abuse when i tell him what the problem was. :tongue:

Re: Sync problem. #57205 24/10/03 02:42 PM
Joined: Oct 2003
Posts: 273
E
EVH Offline
Fjord artisan
Offline
Fjord artisan
E
Joined: Oct 2003
Posts: 273
most welcome smile