mIRC Home    About    Download    Register    News    Help

Print Thread
Strange Problem #40241 07/08/03 06:04 AM
Joined: Aug 2003
Posts: 3
S
sardak Offline OP
Self-satisified door
OP Offline
Self-satisified door
S
Joined: Aug 2003
Posts: 3
I'm having a rather odd problem with my scripts. Periodically, I'll accidentally introduce an infinite loop that I must control+break out of. After the control break, all scripting actions stop working, including aliases, popups, remote, etc.

I've tried unloading and reloading the script files, turning off and back on the remote, events, raw, ctcps, etc. flags. I've tried restarting mIRC.

It seems the only resolution that works is to completely reboot my computer, which I dislike doing for various reasons.

Is there any command or action I can take to resolve this issue without such a drastic solution?

Re: Strange Problem #40242 07/08/03 07:27 AM
Joined: Jul 2003
Posts: 655
Om3n Offline
Fjord artisan
Offline
Fjord artisan
Joined: Jul 2003
Posts: 655
Hmmz, i tried to reproduce the problem myself, but with no luck.
Ctrl+break should ONLY halt the currently active remote/alias ect.

The only thing i can think of is that the alias/remote file that you are using is too large and brackets are being dropped as a result (this has the potential to render the script file useless.) Of corse, that doesn't explain why reloading the scripts would not work. Check you do not have any aliases related to /remote* /reload* ect that would stop them from functioning normally. Other than that i can't think of anything right now.


"Allen is having a small problem and needs help adjusting his attitude" - Flutterby
Re: Strange Problem #40243 07/08/03 03:31 PM
Joined: Aug 2003
Posts: 3
S
sardak Offline OP
Self-satisified door
OP Offline
Self-satisified door
S
Joined: Aug 2003
Posts: 3
I've since deleted the short script that caused the original problem, so my alias file is 29 lines, and my remote file is 12 lines, so length isn't an issue. There are no references to remote or reload anywhere in either file. All brackets match up fine, and in fact, even 1 line aliases cause the problem.

It seems to happen every time for me, odd that it's not reproducable.

Re: Strange Problem #40244 08/08/03 06:23 AM
Joined: Jul 2003
Posts: 655
Om3n Offline
Fjord artisan
Offline
Fjord artisan
Joined: Jul 2003
Posts: 655
Hmmz, yes very troubling lolz... care to share an example of an alises/remote that causes this?


"Allen is having a small problem and needs help adjusting his attitude" - Flutterby
Re: Strange Problem #40245 08/08/03 02:58 PM
Joined: Aug 2003
Posts: 3
S
sardak Offline OP
Self-satisified door
OP Offline
Self-satisified door
S
Joined: Aug 2003
Posts: 3
The original problem began when I was running through a loop, and accidentally /set %i (%i + 1), and it became the string as opposed to the quantity. So, of course, %i was never equal to %n, and it went into an infinite loop. I control+break'd out of this.

Afterwards, any script, no matter how simple or complex, stopped working. Even the popups stopped popping up. As a test, I tried the alias:

/test /echo test

And it caused a break error on that line.