mIRC Home    About    Download    Register    News    Help

Print Thread
I can't resume files for other users #29885 15/06/03 12:52 PM
Joined: Jun 2003
Posts: 2
Z
Zogy Offline OP
Bowl of petunias
OP Offline
Bowl of petunias
Z
Joined: Jun 2003
Posts: 2
I can request a resume OK but when users request a resume from me it gets to the point where the window appears saying "sending request, awaiting reply" and eventually it times out. Also I seem to get disconnected soon after this window appears so I think it's related. The message I get is "connection reset by peer"

confused However my current gets and sends continue to work as normal, I'm guessing that this is because the files are being get/sent directly to the user without going through the server.

laugh Can anybody help me with this.

I've looked at posts regarding send connection issues and they all mention incorrect ip addresses but I've already had problems here and I think I've solved them, also if this were the case I shouldn't be able to send files which I can, it's only resumes that fail.

I'm tempted to uninistall and install OmeNServE again but I'm scared that this will remove my list of requested files.

I should also add that I'm using a Telewest Broadband connection trought a Wireless Router. The firewall on the Router is not enabled and I'm using Zone Alarm as a firewall to which mirc has full server privilages.

Last edited by Zogy; 15/06/03 01:05 PM.

Chris
~~~~~
Re: I can't resume files for other users #29886 15/06/03 08:44 PM
Joined: Dec 2002
Posts: 3,127
P
ParaBrat Offline
Hoopy frood
Offline
Hoopy frood
P
Joined: Dec 2002
Posts: 3,127
It could be that the resume prob is on the other end, not yours.
Have you tried testing on a clean copy of mIRC without any scripts/addons?

Have you seen this thread

You might also check out dslreports website as they may have info re your provider and any limitations


ParaBrat @#mIRCAide DALnet
Re: I can't resume files for other users #29887 22/06/03 12:08 AM
Joined: Jun 2003
Posts: 2
Z
Zogy Offline OP
Bowl of petunias
OP Offline
Bowl of petunias
Z
Joined: Jun 2003
Posts: 2
I've fixed the problem or should I say problems.

Firstly my Netgear MR314 Router does not like Mirc connecting to Undernet servers using port 6667, I had to change the port range to not use 6667 for all the EU Undernet server conenction settings.
This stops the disconnecting after a DCC send is sent which means resumes will work. Note that send kept working even after disconnection because there was no more communication required through the server to initiate the transfer

Secondly I had to set the port forwarding on my router to the same port range set under mirc settings DCC/Options/First & Last. I set 1050-1100 because 1026 seems to be used for something else (I don't know what). I'm not likely to have 50 transfer going at the same time anyway.

So now everything works Wuh HOOO!!!


Chris
~~~~~
Re: I can't resume files for other users #29888 22/06/03 07:21 AM
Joined: Dec 2002
Posts: 3,127
P
ParaBrat Offline
Hoopy frood
Offline
Hoopy frood
P
Joined: Dec 2002
Posts: 3,127
Glad you got the prob solved smile

Yes, as noted in the threads on 10053 (software causes connection abort) Netgear seems to be cranky with ports 6667 and 1026 regarding dcc. Thanks for letting us know the same things seem to also be causing the Peer disconnect error.

And yep, if the send had been initiated, it should keep going even tho you are disconnected from the server, since dcc==direct client to client and only uses the server to start the process.


ParaBrat @#mIRCAide DALnet