mIRC Home    About    Download    Register    News    Help

Print Thread
Joined: Dec 2021
Posts: 2
K
Kerashi Offline OP
Bowl of petunias
OP Offline
Bowl of petunias
K
Joined: Dec 2021
Posts: 2
I've turned this off three times now in the past two days, and it keeps rechecking itself, keeping mIRC on top and preventing me from tabbing to other applications. Not sure what's causing it, since I didn't turn it on to begin with, it turned itself on. On 7.67.

Joined: Dec 2002
Posts: 5,243
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 5,243
Thanks for your bug report. I have not been able to reproduce this issue here so far and have never encountered this myself. Are you using a script of some kind that might be doing this? There are three ways to manually enable this feature: the mIRC window system menu, the View menu or the Options/Display/Options/Windows dialog. Is it possible that you might be enabling it by mistake while browsing through one of these?

Joined: Jan 2004
Posts: 1,988
Hoopy frood
Offline
Hoopy frood
Joined: Jan 2004
Posts: 1,988
There are 2 ways I can think of which a script could be causing this, both of which would be easy to check for.

1. This command enables mirc being ontop: /showmirc -o
2. If you have something that's using the well known /sendkeys alias to do things which can't be done by normal commands or identifiers, if the script isn't written well, there can be sometimes when the keys are entering a menu the wrong way and executing the ontop setting.

But the most likely ways are the 3 ways Khaled mentioned

Joined: Dec 2021
Posts: 2
K
Kerashi Offline OP
Bowl of petunias
OP Offline
Bowl of petunias
K
Joined: Dec 2021
Posts: 2
I checked my scripts, and the only one I have doesn't use either of those commands, so I'm fairly sure that's not it. I haven't experienced it again since reporting it, so not sure what was going on. I might have turned it on in the View menu at one point accidentally (not sure), but it struck me as strange how it would turn on again with no intervention after being turned off. Regardless, everything seems to be behaving normally now, thanks for responding.


Link Copied to Clipboard