mIRC Home    About    Download    Register    News    Help

Print Thread
sockopen -e not working without '46' #266318 15/11/19 10:43 PM
Joined: Aug 2015
Posts: 38
_entropy Offline OP
Ameglian cow
OP Offline
Ameglian cow
Joined: Aug 2015
Posts: 38
when you:

sockopen -e test site.com 443

it doesnt work (use to though)

Now it requires:

sockopen -e46 test site.com 443

Bug maybe?


mIRC Scripts IRC Network: irc://irc.mircscripts.net/chat
Re: sockopen -e not working without '46' [Re: _entropy] #266319 15/11/19 11:03 PM
Joined: Jul 2006
Posts: 3,585
W
Wims Offline
Hoopy frood
Offline
Hoopy frood
W
Joined: Jul 2006
Posts: 3,585
If you're using /sockopen on an ipv4 domain name from a /server -6 connection, -6 completely disables ipv4 for that connection, what's the error message you get?
The -4 switch is there to force ipv4 back in this case, so it's normal.
To get ipv4 to work, you need to use the ipv6 setting which gives priority to ipv6 without disabling ipv4 (use global mode and stop using the -6 switch in /server): https://en.wikichip.org/wiki/mirc/ipv6


Looking for a good help channel about mIRC? Check #mircscripting @ irc.swiftirc.net
Re: sockopen -e not working without '46' [Re: _entropy] #266323 16/11/19 01:28 PM
Joined: Dec 2002
Posts: 4,586
Khaled Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 4,586
Thanks for your bug report. Please include a short script that I can use to reproduce this issue.

Update: I just tried https://site.com:443 in Firefox and the connection keeps failing and timing out.

Last edited by Khaled; 16/11/19 01:48 PM.