mIRC Home    About    Download    Register    News    Help

Topic Options
#264043 - 23/10/18 11:55 AM Problem using ssounds
Lucifuge Offline
Mostly harmless

Registered: 23/10/18
Posts: 1
Problem with sound
i added a friend to my address book and connected a sound file to the nick, all was fine the sound file played. then i decided to change the sound file it did not play when the friend logged on
i tried to revrt back to the previous ile that payed but now it does not play. obviouslu the is a severe user error but this user it utterly lost could some kind soul tell me how to get out of this mess please

Top
#264044 - 23/10/18 04:10 PM Re: Problem using ssounds [Re: Lucifuge]
maroon Offline
Hoopy frood

Registered: 12/01/04
Posts: 969
A few things to try.

1. While testing, they only need to use /nick to change from-then-to the nick. They don't need to actually connect/disconnect from that network. It won't respond to yourself changing nick.

2. Does it display a message that they're here/gone, and just the sound doesn't play? If not, either verify that the notify tab of address book has "enabled" checked, or type: /notify on

3a. See if problem continues when you disable scripts: /remote off
3b. Be sure to turn back on. /remote on.

4. Verify mirc-options/sounds has the box checked "enable sounds"

5. Make sure it lists the nick here: /notify -l

6. Paste this command:

Code:
//var %i $notify(0) | while (%i) { echo -a %i $notify(%i) ison: $notify(%i).ison network: $notify(%i).network $notify(%i).offline $notify(%i).sound | dec %i }



It should correctly report if that nick is here/away. The network should either be blank, or be the correct $network string for that network. (Usually shown in the titlebar of status window or type //echo -a $network ). It should list the path to the sound file.

If it lists the path\filename for a sound, highlight it to paste as the parameter to the /splay command, and you should hear the sound.

If it doesn't list the sound, either you didn't put it into the correct entry in the 'notify' tab, or you put it as offline instead of online.

Edit: If they are online using that nick, this should also trigger the sound without needing a nick change: /notify


Edited by maroon (23/10/18 05:20 PM)

Top