I am experiencing a very strange issue between mIRC and the UnrealIRCd server. I was wondering if anyone else had experienced this or had any suggestions.

For several years, I have run mIRC and UnrealIRCd (version on an internal network with no problems. When I tried upgrading to version 4.0.x (multiple versions over the past many months), I started getting a "Registration Timeout" in mIRC. mIRC then disconnects and retries.

The confusing part is that it works on some machines (5) but not others (3). Based on that alone it is easy to speculate that it is a firewall / port / anti-virus issue. We have checked those possibilities. But the weird part is that I can run version 3.2 and it works fine, switch to 4.0 and it timeouts, switch back to 3.2 and it reconnects and works normal again. The machines that work and don't work are configured pretty much the same. The issue almost HAS to be something different in the configuration of the machines that work and don't work but WE have looked at a lot of ideas with no luck.

I have also written a program that acts as a simple synthetic chat bot for our application. That program doesn't seem to care what version of the server we are running either.

Some additional information... We have tried running on a physical machine and VMs. The server is currently running on a VM. VM is running Server 2008 R2. Most of the client machines are running Win 7.

I have searched through the forums and didn't see any similar issues. I am just hoping someone has an idea of what to try next or even better a fix! Any help or suggestions would be appreciated. Thanks.

-- Mike