mIRC Home    About    Download    Register    News    Help

Print Thread
mIRC 7.4x hangs itself on firct channel connect #256766 14/02/16 09:48 AM
Joined: Feb 2016
Posts: 3
Neko1308 Offline OP
Self-satisified door
OP Offline
Self-satisified door
Joined: Feb 2016
Posts: 3
I noticed this in version 7.41 (which I skipped), and now find the same problem again on version 7.43.

I start mIRC, it starts up fine. It connects to the various networks and resizes the windows for those connections normally.

Once the first channel is actually automatically opened, the channel window shows, but doesn't resize to be stacked among the rest, and mIRC freezes. CPU load goes up to 11% on the mIRC process, and all I can do is kill off the process to try again with the same results.

The hang happens on the first network mIRC starts a channel on, which in my case seems to be irchighway. So the remaining networks do not proceed in joining channels at all. They seem to be connected however.

When returning to version 7.38 the problem does not occur, and mIRC works normally.

On startup mIRC connects to 4 networks. EFNet, Rizon, irchighway and Lunarnet.

;Servers
on *:START: {
pdcc on
server efnet.xs4all.nl
server -m irc.eu.rizon.net
server -m irc.irchighway.net
server -m irc.lunarnet.org
}


On connect to these various networks I've set up timers with 5 second intervals to prevent flooding the network, through the Options bit of the mIRC Options, under the 'Perform' button.

For irchighway:

/join #channel1,#channel2,#channel3

For EFNet:

/timer1 1 5 /join #channel1,#channel2,#channel3
/timer8 1 10 /join #channel4,#channel5


For Lunarnet:

/join #channel1

For Rizon:

/timer11 1 5 /join #channel1,#channel2,#channel3
/timer13 1 10 /join #channel4,#channel5


As stated, it runs the first commenad for the irchighway network, which should open 3 channels in one go. It opens 1, and then immidiatly hangs. The windows completely freezes, menus are not available, and the whole program is just unresponsive at that point.

I've looked though the other posts regarding a hang of mIRC, but have been unable to find a similar problem as the one I'm expiriencing.

Any thoughts on what may cause this?


I reject your reality, and substitute my own - Adam Savage
Re: mIRC 7.4x hangs itself on firct channel connect [Re: Neko1308] #256767 14/02/16 09:54 AM
Joined: Dec 2008
Posts: 1,511
westor Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2008
Posts: 1,511
Can you please execute this command and reply here the results?

Code:
//echo -a $os $version $iif($beta,$beta,0) $md5($mircexe,2) $file($mircexe).sig $alias(0) $script(0) $dll(0) $com(0)

Re: mIRC 7.4x hangs itself on firct channel connect [Re: Neko1308] #256778 14/02/16 09:57 PM
Joined: Dec 2002
Posts: 4,841
Khaled Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 4,841
Thanks for your bug report. I have not yet been able to reproduce this issue by following the steps you described.

If you can please post the output of the //echo command in westor's post, that will help in tracking down the issue.

Also, if you could please try this:

1) Run the mIRC v7.43 installer
2) Choose an mIRC install folder in your Documents folder.
3) Check the "portable" option in the installer.
4) Install mIRC.

Now run mIRC from that folder. Are you still able to reproduce the issue with this copy of mIRC?

Re: mIRC 7.4x hangs itself on firct channel connect [Re: Khaled] #256796 16/02/16 06:55 PM
Joined: Feb 2016
Posts: 3
Neko1308 Offline OP
Self-satisified door
OP Offline
Self-satisified door
Joined: Feb 2016
Posts: 3
Westor - Went with Khaled's reply first... which seems to have narrowed down the problem as a script-bug, and not a bug in mIRC itself. I never did get around to any extensive testing on this. Attributed it to a fluke on version 7.41, and only when it reoccurred on version 7.43 I considered it something that might hint at a bug. Moreso because on every upgrade of mIRC it ran without any issues.

I just installed mIRC 7.43 in a completely separate folder instead of upgrading the existing version (I didn't install it as a portable application, just a completely clean folder). mIRC starts up fine and dandy. Connects properly, and can join channels normally.

Okay, lets see here... Copied all of the INI files, added MRC scripts, DAT file and a heap of folders (sounds, logs, data) over. Started mIRC... it hung itself. Removed all the copied stuff and tried, mIRC started happily.

I just copied all of the INI files over, and tried. mIRC started properly. So it doesn't seem to be a problem in mIRC at all, but rather in something I added in either the script or an add-on.

A couple of mrc-script files, and a DLL file... Copied those, and tried. No problem. Starting normally.

Got a folder 'data', which only contains a settings.ini. No real idea where that one came from, but copied it over. Contents of the INI file make me doubt severely that it is the cause, but still want to exclude it from my suspect list. mIRC still starts normally.

In which case I'm left with one folder that I did not yet copy... GTSDLL to announce what mediaplayer/winamp is doing... I haven't used mIRC in a while, so that might also be outdated. Looked in the changes.txt file, and found the version I apparently have is 1.2.7.3. Which according to http://www.gts-stuff.com/index.php/topic,1664.0.html is the last one...

Copied it over, and tried... No clue what the heck changed, but mIRC just started normally too... So it's not that either. Tho I did notice GTSDLL isn't loaded in mIRC 7.43. Whereas it IS loaded in version 7.38.

So then I ran through the ini files, and found the rfiles-section in mirc.ini which points at the gtsdll.ini file. This section differs in the mirc.ini files between the two versions tho. Apparently it dumps everything it can't find out on starting.

There's two lines in the original 7.38 version that are not in the copy (7.43) anymore:

opme.mrc
GTSDLL\gtsdll.ini

These lines were probably deleted on my first start of mIRC, where I hadn't copied the MRC script, nor had I copied GTSDLL.

I recall (vaguely) the opme script was included to use a backdoor to talk to a bot as a non-admin user, and push the bot into giving you operator status based on a password held in the bot-config. So you could gain channel-ops even if your ident wasn't recognized by any of the bots in the channel. Not using that anymore, heck some of the bots it was used with don't even exist anymore.

Still added the extra line to include opme.mrc to the mirc.ini file, and kicked off mIRC 7.43. And it hung itself. Completely.

Swapped that line out with the GTSDLL bit to see if that one worked fine, started mIRC, and it works normally. So the culprit is the opme.mrc script that doesn't cause a hang with version 7.38, but does hang mIRC completely with version 7.43. Guess we can scrap this one as a bug, and more or less contribute it to some shoddy 3rd party coding.

Solved.


I reject your reality, and substitute my own - Adam Savage
Re: mIRC 7.4x hangs itself on firct channel connect [Re: Neko1308] #256798 16/02/16 07:49 PM
Joined: Dec 2002
Posts: 4,841
Khaled Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 4,841
Thanks for tracking it down, much appreciated.

Update: the issue turned out to be a while/if bracket parsing bug caused by a specific combination of split lines, | separators, and } closing brackets. This has been fixed for the next version.

Last edited by Khaled; 17/02/16 10:04 AM.
Re: mIRC 7.4x hangs itself on firct channel connect [Re: Khaled] #256806 17/02/16 06:44 PM
Joined: Feb 2016
Posts: 3
Neko1308 Offline OP
Self-satisified door
OP Offline
Self-satisified door
Joined: Feb 2016
Posts: 3
I stand corrected on shoddy coding, and retract my bug statement smile

Glad I could help smile


I reject your reality, and substitute my own - Adam Savage