mIRC Home    About    Download    Register    News    Help

Print Thread
7.22 ident #235320 09/12/11 01:37 AM
Joined: Apr 2003
Posts: 85
K
katsklaw Offline OP
Babel fish
OP Offline
Babel fish
K
Joined: Apr 2003
Posts: 85
7.22 pulls username from email address even when option is unchecked.


--

katsklaw
Rather experienced Admin
Rather experienced mIRC Scripter
Amateur C Coder
Re: 7.22 ident [Re: katsklaw] #235323 09/12/11 04:25 AM
Joined: Jan 2004
Posts: 1,206
maroon Offline
Hoopy frood
Offline
Hoopy frood
Joined: Jan 2004
Posts: 1,206
just an aside.
i've seen this issue before being caused by the irc network. i remember a network having this issue where the username coming from identd or email@ value was dependant on which of their servers i connected to, so you might want to test on different servers as well as different mirc versions.

Re: 7.22 ident [Re: maroon] #235326 09/12/11 05:49 AM
Joined: Apr 2003
Posts: 85
K
katsklaw Offline OP
Babel fish
OP Offline
Babel fish
K
Joined: Apr 2003
Posts: 85
I have tried multiple ircds/networks and versions. mIRC 7.1 is doing it too.


--

katsklaw
Rather experienced Admin
Rather experienced mIRC Scripter
Amateur C Coder
Re: 7.22 ident [Re: katsklaw] #235350 10/12/11 05:06 PM
Joined: Dec 2002
Posts: 3,138
C
Collective Offline
Hoopy frood
Offline
Hoopy frood
C
Joined: Dec 2002
Posts: 3,138
I can't reproduce this. Do you have more than one mIRC instance running? Are you sure mIRC's identd server is responding at all (no ~ in your whois)? What is the output if you enable "Show Identd requests"?

Re: 7.22 ident [Re: Collective] #235355 10/12/11 07:15 PM
Joined: Apr 2003
Posts: 85
K
katsklaw Offline OP
Babel fish
OP Offline
Babel fish
K
Joined: Apr 2003
Posts: 85
Originally Posted By: Collective
I can't reproduce this. Do you have more than one mIRC instance running?

no, but I do connect to more than 1 net. Some forced identd and some dont.

Quote:
Are you sure mIRC's identd server is responding at all (no ~ in your whois)?


Yes it's enabled.

~ is provided by the ircd, not mIRC. It only appears if identd checks are forced and not found. In all cases though regardless of ircd configuration, my username is still my email prefix.

Quote:
What is the output if you enable "Show Identd requests"?


I'm firewalled not unlike most everyone else that uses home based broadband and I do not allow ident through. It's irrelevant and pointless in todays technology.

Regardless though, mIRC should use my username as specified and not the prefix when that option is not checked, regardless of what the outside world sees because mIRC SENDS the data, the ircd doesn't RETRIEVE the data.

Debug:
Code:
-> rock.hidden.com NICK katsklaw
-> rock.hidden.com USER me 0 * :Who Dat?!


Email is set to 'me@home.com' username is set to 'darkness'. Use ID from email is not enabled. It's still set to 'me' regardless of if Use Ident server is set as well.


--

katsklaw
Rather experienced Admin
Rather experienced mIRC Scripter
Amateur C Coder
Re: 7.22 ident [Re: katsklaw] #235357 10/12/11 07:25 PM
Joined: Dec 2002
Posts: 3,138
C
Collective Offline
Hoopy frood
Offline
Hoopy frood
C
Joined: Dec 2002
Posts: 3,138
This is how mIRC has always behaved and it is not a bug. The "Use ID from email address" setting refers to the identd server, and since you are blocking identd it naturally has no effect. This also means the correct answer to my second question was "No".

Re: 7.22 ident [Re: Collective] #235359 10/12/11 07:31 PM
Joined: Apr 2003
Posts: 85
K
katsklaw Offline OP
Babel fish
OP Offline
Babel fish
K
Joined: Apr 2003
Posts: 85
*sigh* blocking ident is irrelevant as I stated because it's mIRC sending the data. It SENDS 'me' instead of 'darkness', regardless of client settings. This also happens on a local ircd behind my identd block.

What I'm talking about happens before any firewall/identd or ircd is even involved.

EDIT:

This is from my local ircd.
Code:
-> 127.0.0.1 CAP LS
-> 127.0.0.1 NICK katsklaw
-> 127.0.0.1 USER me 0 * :Who Dat?!


That should say -> 127.0.0.1 USER darkness 0 * :Who Dat?!

Again this is what mIRC is SENDING to the ircd and it's sent regardelss of if I have identd on or off and regardless of if I enable use ID from email or not. This is inside my firewall and a direct connection to 127.0.0.1.

Last edited by katsklaw; 10/12/11 07:45 PM.

--

katsklaw
Rather experienced Admin
Rather experienced mIRC Scripter
Amateur C Coder
Re: 7.22 ident [Re: katsklaw] #235360 10/12/11 07:48 PM
Joined: Dec 2002
Posts: 3,138
C
Collective Offline
Hoopy frood
Offline
Hoopy frood
C
Joined: Dec 2002
Posts: 3,138
How can your blocking of identd not be relevant to an identd setting? It's the identd setting that's not relevant here, since you're actually complaining about the USER command mIRC sends.

The USER parameter and ID are not related. Originally they were expected to be the same, but they were also expected to be the name of a valid user account on the remote client's system. Things have moved on a bit and the USER parameter is now more likely to refer to some kind of account on the IRC server if it has any meaning at all. identd has also become deprecated as something of a security liability, and mIRC deliberately allows you to set ID and username independently in order to provide customizability and compatability.

Re: 7.22 ident [Re: katsklaw] #235361 10/12/11 08:32 PM
Joined: Oct 2004
Posts: 8,327
Riamus2 Offline
Hoopy frood
Offline
Hoopy frood
Joined: Oct 2004
Posts: 8,327
It works fine for me. I usually have email blank since there really isn't any reason to have anything there. But even if I put something in it, as long as I have the email box unchecked in the identd settings AND identd is enabled, the identd username is used.

If identd is disabled, then it will of course use the email (it should).


Invision Support
#Invision on irc.irchighway.net
Re: 7.22 ident [Re: katsklaw] #235364 10/12/11 10:15 PM
Joined: Oct 2003
Posts: 3,918
A
argv0 Offline
Hoopy frood
Offline
Hoopy frood
A
Joined: Oct 2003
Posts: 3,918
You're confused about the way IRC connection handshaking works. When you provide an ident response from the IDENTD server, the username supplied to the server is discarded. Your actual ident server will be sending "darkness" as you told it to-- what is sent in the USER command is irrelevant, because it is not used by the server. In other words, if you identd server is working, the data you supplied in the USER command doesn't matter-- unless of course the identd server does not work, in which case the options you set in your Ident panel are not going to be used anyway, because that feature is not working / disabled.

In case you are confused about the terminology, "ident" and "username" are two different things. You don't send the server "your ident". You send the server your username. In mIRC this field is defined as the email address. The ident is a completely separate value from username. This is something the server checks for. If there is an ident response, the server uses it. Your statement that "the server provides ~" is inaccurate. The server doesn't tack on ~ to any value you give it. The ~ specifically denotes that the server could not lookup the ident value and is using the value supplied in your USER command instead. In other words, "~" means that your ident server is not working. If your ident server is not working, you should not expect mIRC to be using anything you configured in a panel called "Ident". mIRC will always send the id part of your email field in the USER command-- that server command is not related to how the Ident panel is configured. These are two separate values, and unchecking "[ ] Use id from email address" does not tell mIRC to use the username from the ident panel; that's not how the setting works. You can tell mIRC to use the value from your username as the response for the identd server, but you cannot tell mIRC to use the response from the identd server as the username value.

If you want mIRC to use your identd info as your username as well, make it your email address id and tell mIRC to use that id instead. That's why the setting exists.


- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"
Re: 7.22 ident [Re: argv0] #235368 11/12/11 12:01 AM
Joined: Dec 2002
Posts: 339
D
drum Offline
Fjord artisan
Offline
Fjord artisan
D
Joined: Dec 2002
Posts: 339
Originally Posted By: argv0
You can tell mIRC to use the value from your username as the response for the identd server, but you cannot tell mIRC to use the response from the identd server as the username value.


You can actually. Just leave the email field blank. If the OP does this, it would work the way he wants it to.