mIRC Home    About    Download    Register    News    Help

Print Thread
mIRC Window always sits on top of others #228313 17/12/10 03:14 AM
Joined: Nov 2007
Posts: 20
D
Drai Offline OP
Ameglian cow
OP Offline
Ameglian cow
D
Joined: Nov 2007
Posts: 20
Basically if I open firefox, iTunes, etc the mIRC window always sits on top until I minimize it. Is there a setting that can be changed? It never did this when I used Windows Vista but ever since I got my new computer with Windows 7 I've had this problem.

I'm using the most current version of mIRC as far as I know.

When I click on the icon at the top left of mIRC the 'on top' option is greyed out.

Thanks

Last edited by Drai; 17/12/10 03:29 AM.
Re: mIRC Window always sits on top of others [Re: Drai] #228318 17/12/10 12:47 PM
Joined: Dec 2002
Posts: 4,829
Khaled Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 4,829
This usually indicates that you have the "on top" setting enabled for the main mIRC window. You can change this setting by clicking the small mIRC icon in the top left corner of the mIRC window and unchecking the "on top" option. The setting can also be changed in the mIRC Options/Display/Options/Windows dialog.

Re: mIRC Window always sits on top of others [Re: Khaled] #228323 17/12/10 10:05 PM
Joined: Nov 2007
Posts: 20
D
Drai Offline OP
Ameglian cow
OP Offline
Ameglian cow
D
Joined: Nov 2007
Posts: 20
Thank you so much. Like I said, the mIRC icon in the top left corner showed the 'on top' option but it was greyed out. However the second suggestion you had did the trick.

Appreciate it!

Re: mIRC Window always sits on top of others [Re: Khaled] #267778 25/09/20 07:48 AM
Joined: Jan 2018
Posts: 3
M
MistressCarolyn Offline
Self-satisfied door
Offline
Self-satisfied door
M
Joined: Jan 2018
Posts: 3
I realize this is an old post, but I'm having this problem now myself... I've done what you suggested and checked the "on top" setting in both places. It was off, so I togged it on and off again in each place, none of this made any difference, and the mIRC window is still stuck on top of my windows task bar so I can't pull it up by moving the mouse to the bottom of the screen while the mIRC window is maximized frown

Any help would be appreciated

Re: mIRC Window always sits on top of others [Re: MistressCarolyn] #267780 25/09/20 10:09 AM
Joined: Dec 2002
Posts: 4,829
Khaled Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 4,829
To check whether the "on top" setting is working correctly...

If you turn "on top" on and then try to switch to other applications, does mIRC stay on top of all other windows? If it does, this means "on top" is working correctly.

If you turn "on top" off and then try to switch to other applications, do other windows cover the mIRC window? It they do, this means "on top" has been turned off correctly.

At this point, if your Windows task bar is still being covered by mIRC, something else is going on that is not related to mIRC.

You could try changing your taskbar settings, or moving the taskbar around. These seem to resolve the issue for some Windows users.

You could also try logging out of, or restarting, Windows.

Re: mIRC Window always sits on top of others [Re: Khaled] #267783 27/09/20 03:44 PM
Joined: Sep 2020
Posts: 1
N
n9ds Offline
Mostly harmless
Offline
Mostly harmless
N
Joined: Sep 2020
Posts: 1
I've been running mIRC for years on this box (XP), currently 7.55 and suddenly (within the past month or so) started having this problem. "On Top" is not checked. If I check it, and then uncheck it, it works as expected until I switch back to the mIRC window, and then it gets stuck on top again. The box itself hasn't changed in a long time and is used almost exclusively via remote desktop for mIRC.

Re: mIRC Window always sits on top of others [Re: n9ds] #267785 27/09/20 04:41 PM
Joined: Dec 2002
Posts: 4,829
Khaled Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 4,829
If you have followed the steps described in my post above, and the "on top" setting is turned off, this means that the issue is not related to mIRC. There is nothing you can do in mIRC to prevent this. The issue is with your Windows taskbar.

Re: mIRC Window always sits on top of others [Re: n9ds] #267795 29/09/20 05:38 PM
Joined: Jul 2006
Posts: 3,723
W
Wims Offline
Hoopy frood
Offline
Hoopy frood
W
Joined: Jul 2006
Posts: 3,723
Note that there is a on top setting as well in alt + o > display > options > windows... but I tried it and it's working as expected on 7.63: accessing the window's menu of the main mIRC window shows the on top setting, and disabling it there does work, unsetting the checkbox in alt + o as well as making the window not on top.
Make sure the value of $file($mircexe).sig is "ok", try to use the latest version of mIRC.


Looking for a good help channel about mIRC? Check #mircscripting @ irc.swiftirc.net