mIRC Home    About    Download    Register    News    Help

Print Thread
ignore problem #227895 27/11/10 05:13 PM
Joined: Dec 2009
Posts: 9
L
lionheart Offline OP
Nutrimatic drinks dispenser
OP Offline
Nutrimatic drinks dispenser
L
Joined: Dec 2009
Posts: 9
Hello,
My ignore doesn't work properly. I put someone on ignore, and the same person, with the same nick/info, same everything, can msg me again right after I disconnect and come back. Even if I only disconnect for a few seconds. Someone help please, it's very annoying to have to reignore the same people over and over again. I'm using version 7.1, but had the same issue with the previous version.
Thanks

Re: ignore problem [Re: lionheart] #227896 27/11/10 06:18 PM
Joined: Dec 2002
Posts: 2,021
R
RoCk Offline
Hoopy frood
Offline
Hoopy frood
R
Joined: Dec 2002
Posts: 2,021

Do you have a query window open for this person? If so, the open query window will override ignore and allow the private message through. Also, make sure ignore is enabled by typing /ignore on

Re: ignore problem [Re: RoCk] #227923 28/11/10 04:39 PM
Joined: Dec 2009
Posts: 9
L
lionheart Offline OP
Nutrimatic drinks dispenser
OP Offline
Nutrimatic drinks dispenser
L
Joined: Dec 2009
Posts: 9
If the ignore was working, the query window wouldn't appear.

Re: ignore problem [Re: lionheart] #227924 28/11/10 05:21 PM
Joined: Dec 2002
Posts: 2,021
R
RoCk Offline
Hoopy frood
Offline
Hoopy frood
R
Joined: Dec 2002
Posts: 2,021

I meant, if there is already a query window open for this person, then that would override ignore and allow the message through.

Re: ignore problem [Re: lionheart] #227925 28/11/10 05:44 PM
Joined: Jan 2007
Posts: 1,156
D
DJ_Sol Offline
Hoopy frood
Offline
Hoopy frood
D
Joined: Jan 2007
Posts: 1,156
What command do you use for ignore. What nick identifier do you use? Do you check for it in the ignore list? $ignore(mask)

Re: ignore problem [Re: RoCk] #228037 04/12/10 01:17 AM
Joined: Dec 2009
Posts: 9
L
lionheart Offline OP
Nutrimatic drinks dispenser
OP Offline
Nutrimatic drinks dispenser
L
Joined: Dec 2009
Posts: 9
I've put the person on ignore without opening the query window by typing it in manually, ie: /ignore bozo, or with a right click-ignore, then closing it, and I've tried doing the same thing without opening the query window. Either way, the next time I connect, wether it's in 2 seconds or 2 weeks, bingo, the same person can msg me again. I don't know what the heck is going on.

Re: ignore problem [Re: lionheart] #228054 04/12/10 03:01 PM
Joined: Jun 2003
Posts: 994
C
CtrlAltDel Offline
Hoopy frood
Offline
Hoopy frood
C
Joined: Jun 2003
Posts: 994
Just a thought ... is ignore enabled? Try typing /ignore on


I refuse to engage in a battle of wits with an unarmed person. wink
Re: ignore problem [Re: CtrlAltDel] #228069 04/12/10 05:30 PM
Joined: Dec 2009
Posts: 9
L
lionheart Offline OP
Nutrimatic drinks dispenser
OP Offline
Nutrimatic drinks dispenser
L
Joined: Dec 2009
Posts: 9
Yep, it's on. Tried that, no change.

Re: ignore problem [Re: DJ_Sol] #228070 04/12/10 05:31 PM
Joined: Dec 2009
Posts: 9
L
lionheart Offline OP
Nutrimatic drinks dispenser
OP Offline
Nutrimatic drinks dispenser
L
Joined: Dec 2009
Posts: 9
I use /ignore, or I right click-ignore.

Re: ignore problem [Re: lionheart] #228071 04/12/10 05:33 PM
Joined: Dec 2009
Posts: 9
L
lionheart Offline OP
Nutrimatic drinks dispenser
OP Offline
Nutrimatic drinks dispenser
L
Joined: Dec 2009
Posts: 9
Here's a twist that maybe will point someone in the right direction to help me out here. I deleted every address in my ignore list. When I reconnected, all of them were back. They are also set to ignore on a network I'm not even on, but apparently not set to ignore on the network I am on.

Re: ignore problem [Re: lionheart] #228072 04/12/10 05:41 PM
Joined: Jun 2007
Posts: 933
5
5618 Offline
Hoopy frood
Offline
Hoopy frood
5
Joined: Jun 2007
Posts: 933
What does this return?
Code:
//echo -a $os $version $md5($mircexe,2) $script(0) $dll(0) $mircdir

Re: ignore problem [Re: lionheart] #228079 05/12/10 01:46 PM
Joined: Oct 2004
Posts: 8,330
Riamus2 Offline
Hoopy frood
Offline
Hoopy frood
Joined: Oct 2004
Posts: 8,330
If you are using Windows Vista or Windows 7, you may have the mIRC.ini file in a folder that you cannot write to. Check your permissions on that folder. It could also be related to another script or DLL, so reply with what the command above gives you.


Invision Support
#Invision on irc.irchighway.net
Re: ignore problem [Re: lionheart] #228084 06/12/10 05:24 AM
Joined: Jan 2007
Posts: 1,156
D
DJ_Sol Offline
Hoopy frood
Offline
Hoopy frood
D
Joined: Jan 2007
Posts: 1,156
This has only happened to me with the variables file so far. I don't know if it's an issue with the control.ini file. And I thought I heard about a fix done for this issue, but just in case...

Do you manually edit the control file while mirc is running? I noticed this same behavior happening with my variables. I would restart mirc and the changes I had made were gone. I checked the actual file and I saw two [variables] sections in the file. mIRC would only read the 1st one on startup. It would happen when I manually edited the file while mirc was running.

Re: ignore problem [Re: DJ_Sol] #228098 07/12/10 12:08 AM
Joined: Aug 2004
Posts: 7,252
R
RusselB Offline
Hoopy frood
Offline
Hoopy frood
R
Joined: Aug 2004
Posts: 7,252
To my knowledge, when mIRC is closed, any manual changes made to the active .ini files (mirc.ini, servers.ini, control.ini, etc.) will be over-written.

If you want to make changes to those files, either do so while mIRC is closed, or use mIRC's internal functions to make the changes. Most (if not all) changes that you would want to make can be made using mIRC's internal functions. These functions are, generally, available through the Options section (Alt + o)


Re: ignore problem [Re: DJ_Sol] #228176 11/12/10 03:00 AM
Joined: Dec 2009
Posts: 9
L
lionheart Offline OP
Nutrimatic drinks dispenser
OP Offline
Nutrimatic drinks dispenser
L
Joined: Dec 2009
Posts: 9
I've never fiddled with any files. I have no clue how to do that even if I wanted to. If I tried, I'd probably ended up killing the thing entirely. hehe.