mIRC Home    About    Download    Register    News    Help

Page 1 of 2 1 2 >
Topic Options
#224925 - 22/08/10 04:19 AM Odd problem [mIRC 7.1]
Chrislog Offline
Ameglian cow

Registered: 22/08/10
Posts: 21
Odd problem when using mIRC7.1 (Not neccesarily chatting or doing anything)
mIRC randomly starts displaying content from other channels in the active window after it's been open for a while (no approx timescale)..

Ex: #Channel content is displaying in #Channel.Two and when I switch to #Channel stuff from #Channel.Two is displaying in #Channel... It seems to get worse as I switch channels, and this happens randomly without any known reason.. It does it with all the channels once you start changing window to see if the others are alright..

Anyone have any solutions to this, as it's becoming increasingly annoying to restart mIRC all the time and I've tried unstalling and re-installing the program, but it doesn't seem to solve anything..

Top
#224928 - 22/08/10 04:44 AM Re: Odd problem [mIRC 7.1] [Re: Chrislog]
RusselB Offline
Planetary brain

Registered: 03/08/04
Posts: 7252
Loc: Ontario, Canada
Please enter the following and report back the results
Code:
//echo -a $os $version $md5($mircexe,2) $file(mirc.exe).sig $script(0) $dll(0)


Quickly, and without that information, my first guess is that you have a script installed that is capturing the text, then echoing it in your active channel.

Top
#224932 - 22/08/10 08:50 AM Re: Odd problem [mIRC 7.1] [Re: Chrislog]
FroggieDaFrog Offline
Hoopy frood

Registered: 16/04/10
Posts: 910
Loc: USA
Are you using the treeview/treebar?
_________________________
I am SReject
My Stuff

Top
#224935 - 22/08/10 11:40 AM Re: Odd problem [mIRC 7.1] [Re: RusselB]
Chrislog Offline
Ameglian cow

Registered: 22/08/10
Posts: 21
Originally Posted By: RusselB
Please enter the following and report back the results
Code:
//echo -a $os $version $md5($mircexe,2) $file(mirc.exe).sig $script(0) $dll(0)


Quickly, and without that information, my first guess is that you have a script installed that is capturing the text, then echoing it in your active channel.


7 7.1 972d762e7e0ce8540400eebaaccd0ee0 fail 14 0

Originally Posted By: FroggieDaFrog
Are you using the treeview/treebar?


Treebar, Yes

Top
#224948 - 22/08/10 07:43 PM Re: Odd problem [mIRC 7.1] [Re: Chrislog]
RusselB Offline
Planetary brain

Registered: 03/08/04
Posts: 7252
Loc: Ontario, Canada
The information you have given tells me that you have 14 scripts loaded.
Unload all of those scripts or install mIRC to a clean directory (no scripts, no add-ons).

Additionally I have to wonder where you got your copy of mIRC, since the signature on the executable failed.

You should download mIRC from here

After doing this see if the same thing happens. If it doesn't, then it is a matter of a script that you have loaded, as I originally suspected.

Top
#224962 - 22/08/10 11:07 PM Re: Odd problem [mIRC 7.1] [Re: RusselB]
Chrislog Offline
Ameglian cow

Registered: 22/08/10
Posts: 21
I only ever download mIRC from this site.. and I'm a registered user of mIRC. I don't lack common sense when it comes to downloading. But I shall reinstall it to a clean directory.

Edit: Also, I've downloaded mIRC yet again from mirc.com, and it still fails it's own signature. I right click for Properties on mirc.exe and the Digital Signature is Listed.

Apparant issue with command you supplied as it 'fails' all the time.

7 7.1 972d762e7e0ce8540400eebaaccd0ee0 fail 1 0


Edited by Chrislog (22/08/10 11:36 PM)

Top
#224964 - 23/08/10 12:07 AM Re: Odd problem [mIRC 7.1] [Re: Chrislog]
argv0 Offline
Planetary brain

Registered: 13/10/03
Posts: 3918
Loc: Montreal, QC, Canada
Something is certainly wrong with your install. Do an uninstall before reinstalling and make sure you delete all your settings first (you can back them up first, if you want). If this problem persists it could be a problem with windows.
_________________________
- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"

Top
#224965 - 23/08/10 12:31 AM Re: Odd problem [mIRC 7.1] [Re: Chrislog]
Collective Offline
Planetary brain

Registered: 10/12/02
Posts: 3138
Loc: London, UK
It's likely failing because there is no mirc.exe in $mircdir in a default install. Try: //echo -a $file([color:red]$mircexe).sig[/color]

Top
#224994 - 23/08/10 04:41 PM Re: Odd problem [mIRC 7.1] [Re: Collective]
Chrislog Offline
Ameglian cow

Registered: 22/08/10
Posts: 21
Originally Posted By: Collective
It's likely failing because there is no mirc.exe in $mircdir in a default install. Try: //echo -a $file([color:red]$mircexe).sig[/color]


Response: ok
Appears you are right on that. smile

Also I'm still having the issue, without any scripts loaded. I've NEVER had any problems with Previous versions. This is ridiculous.

Anyone got the mIRC6.35 installer? I'd like to revert to that version. Can't be doing with it breaking all the time when I have important stuff I need to deal with smirk


Edited by Chrislog (23/08/10 06:13 PM)

Top
#225066 - 24/08/10 11:10 PM Re: Odd problem [mIRC 7.1] [Re: Chrislog]
argv0 Offline
Planetary brain

Registered: 13/10/03
Posts: 3918
Loc: Montreal, QC, Canada
By any chance are you using mIRC under Wine?
_________________________
- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"

Top
#225075 - 25/08/10 07:40 AM Re: Odd problem [mIRC 7.1] [Re: argv0]
Chrislog Offline
Ameglian cow

Registered: 22/08/10
Posts: 21
Wine? No - I download mIRC from mirc.com/get.html, I install it from there and then open and run it from there. It's rather odd why this bug happens as I haven't had any previous problems with any of my scripts on previous versions.. 6.35 Still works perferct for me.. 7.1 Just starts showing conversations from other channels in the active window smirk

Top
#225079 - 25/08/10 09:22 AM Re: Odd problem [mIRC 7.1] [Re: Chrislog]
5618 Offline
Hoopy frood

Registered: 18/06/07
Posts: 933
Are you sure that you tested this in a clean install? Were no scripts, DLLs, etc. loaded at the time?

Do the channels from where the text originates or where it ends up in contain any special characters by any chance?


Edited by 5618 (25/08/10 09:25 AM)

Top
#225086 - 25/08/10 12:37 PM Re: Odd problem [mIRC 7.1] [Re: Chrislog]
Khaled Offline


Planetary brain

Registered: 04/12/02
Posts: 4379
Loc: London, UK
It is possible that this is related to the issue reported here which has been fixed for the next version. I should be releasing a public beta within the next week or so (it will be announced in the bug reports section) - if you could try that when it comes out and let us know if the issue is still there that would be appreciated.

Top
#225089 - 25/08/10 04:22 PM Re: Odd problem [mIRC 7.1] [Re: Khaled]
Chrislog Offline
Ameglian cow

Registered: 22/08/10
Posts: 21
Hmm, it doesn't seem to have done it since I unloaded all of Remotes and Restarted it, I'll try loading in the scripts one by one to see if anything happens.. It's totally random when it happens though.. Thanks Khaled but I can't be sure it's the same problem as I'm having, I will screenshot it the next time it happens and post it here. Thanks

Top
#225091 - 25/08/10 05:13 PM Re: Odd problem [mIRC 7.1] [Re: Chrislog]
Chrislog Offline
Ameglian cow

Registered: 22/08/10
Posts: 21
Excuse the double post.

I kept all the scripts unloaded and waited it out, it seems the issue reproduced itself, I screenshot the problem.

http://i909.photobucket.com/albums/ac300/chrisalog/oddbug.png

Whenever it happens and I or someone say's something in the active window, more stuff from other channels I have open appears in active window. When I scroll up, it's like its changing as I scroll and it adds more stuff again.. When I minimize and maximize the window, the display fault is gone... and it looks how it should, without the mixture of stuff from other windows.

Hope this helps


Edited by Chrislog (25/08/10 05:14 PM)

Top
#225205 - 28/08/10 02:16 AM Re: Odd problem [mIRC 7.1] [Re: Chrislog]
Chrislog Offline
Ameglian cow

Registered: 22/08/10
Posts: 21
Anyone have anymore ideas? ^

Top
#225252 - 29/08/10 12:28 PM Re: Odd problem [mIRC 7.1] [Re: Chrislog]
Khaled Offline


Planetary brain

Registered: 04/12/02
Posts: 4379
Loc: London, UK
Thanks, this looks like it is the same issue. If it is still present in the public beta (which should be released in the next week or so) please let me know.

Top
#225283 - 29/08/10 11:39 PM Re: Odd problem [mIRC 7.1] [Re: Khaled]
Chrislog Offline
Ameglian cow

Registered: 22/08/10
Posts: 21
Ah ok, thanks Khaled smile

Top
#226302 - 26/09/10 01:52 AM Re: Odd problem [mIRC 7.1] [Re: Chrislog]
Chrislog Offline
Ameglian cow

Registered: 22/08/10
Posts: 21
This problem still occurs in Beta Khaled, below is some screenshots I took of the problem occuring in Beta.

http://img843.imageshack.us/i/26200237.png
http://img39.imageshack.us/i/issueb.png

Any Help would be appreciated, I also emailed you but recieved no reply.

Regards,

Chris

Top
#226309 - 26/09/10 09:10 AM Re: Odd problem [mIRC 7.1] [Re: Chrislog]
drum Offline
Fjord artisan

Registered: 08/12/02
Posts: 339
Chrislog, your images from your last post do not load properly for me.

Top
Page 1 of 2 1 2 >