mIRC Home    About    Download    Register    News    Help

Page 1 of 2 1 2 >
Topic Options
#211978 - 07/05/09 01:04 AM Typing lag mirc 6.35
Shocky Offline
Nutrimatic drinks dispenser

Registered: 29/10/07
Posts: 4
Hello,

I have noticed a major and annoying problem with latest mirc 6.35.
I am using windows 7 RC1 so it could be that but someone told me he noticed the same thing on windows vista but since mirc 6.32 or so.

The problem is when i type actively in the editbox or channels or query, sometimes i never see my characters. I have to wait up to 15 seconds to see them "coming". So this is kinda wierd... Anybody else having this problem?

Thanks

Top
#211983 - 07/05/09 01:37 AM Re: Typing lag mirc 6.35 [Re: Shocky]
Wims Offline
Planetary brain

Registered: 31/07/06
Posts: 3438
Loc: France
More than weird, it not normal.
Window 7 could be the problem but I doubt it is the case here...
People on vista that noticed this too should try a clean mIRC 6.35 with no script loaded, usually script are cause of problems.
_________________________
Looking for a good help channel about mIRC? Check #mircscripting @ irc.swiftirc.net

Top
#211984 - 07/05/09 01:47 AM Re: Typing lag mirc 6.35 [Re: Shocky]
argv0 Offline
Planetary brain

Registered: 13/10/03
Posts: 3918
Loc: Montreal, QC, Canada
Are you pasting input? More specifically are you pasting unicode input? mIRC usually freezes the first time it tries to render unicode if your font does not support unicode and font linking is on (might still occur without font linking as well). Note the default font (fixedsys) does not support unicode.

Also, in mIRC type:

//echo -a $md5($mircexe,2) $script(0) $dll(0) $version $os

Report the results here.

If you're running any scripts you should reinstall a fresh copy of mirc without scripts and verify that it still happens.
_________________________
- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"

Top
#211985 - 07/05/09 02:06 AM Re: Typing lag mirc 6.35 [Re: argv0]
Shocky Offline
Nutrimatic drinks dispenser

Registered: 29/10/07
Posts: 4
I am not pasting... it is during typing.
I currently have mircryption suite loaded as scripts.

Your command gives me:
877f45a0d205e409a7c2d4c87f03fe90 6 1 6.35 Vista

Thanks

Top
#211989 - 07/05/09 06:10 AM Re: Typing lag mirc 6.35 [Re: argv0]
genius_at_work Offline
Hoopy frood

Registered: 08/10/05
Posts: 1741
2f63a83968f9586fe4fb48134253619c 21 0 6.35 Vista

Top
#211990 - 07/05/09 07:43 AM Re: Typing lag mirc 6.35 [Re: Shocky]
argv0 Offline
Planetary brain

Registered: 13/10/03
Posts: 3918
Loc: Montreal, QC, Canada
You've directly modified the mIRC executable which violates the EULA (license agreement). We cannot offer you support. Download mIRC from http://www.mirc.com and try this on a COMPLETELY FRESH install of mIRC with no scripts running. I have a good feeling that without mirccryption modifying what you send and receive from the server, mIRC will likely render text a lot more responsively.
_________________________
- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"

Top
#211996 - 07/05/09 02:03 PM Re: Typing lag mirc 6.35 [Re: Wims]
Excalibur Offline
Vogon poet

Registered: 07/05/09
Posts: 139
Loc: FL, US
No it isn't
I've been using Windows 7 for a long time and I had no issues with mIRC, it actually runs on Windows 7 as smooth as it runs on XP, if not better.
_________________________
- Excalibur
- Good and Evil, there never is one without the other.

Top
#211997 - 07/05/09 02:07 PM Re: Typing lag mirc 6.35 [Re: Excalibur]
RoCk Offline
Hoopy frood

Registered: 16/12/02
Posts: 2007

Same here, no problems whatsoever on Win7.

~ Edit ~

x86 & x64


Top
#212029 - 08/05/09 09:58 PM Re: Typing lag mirc 6.35 [Re: Shocky]
vexed2 Offline
Fjord artisan

Registered: 31/03/07
Posts: 218
I use mIRC 6.35 successfully on Windows 7 too. However, i noticed a typing lag on a script i started making, then while i was trying to work this out i also noticed on my dcx sbar, the timers were going up up 2's even though the timer was supposed to update every second. I don't know what the problem was to be exact, but i run AVG 8.5 so i set an exception to the whole mIRC directory C:\mIRCscript and clicked apply, and bingo! It fixed the typing lag and the delay in the timer. So obviously the realtime scanning must have had something to do with this and maybe it's because of how Windows 7 works now. I can't say with certainty, but it worked for me. smile

Top
#213046 - 16/06/09 05:21 AM Re: Typing lag mirc 6.35 [Re: Shocky]
kogitsune Offline
Mostly harmless

Registered: 16/06/09
Posts: 1
I have this same sort of issue... I've already posted to a topic someone started on the Windows 7 forum but there's no replies at all so far.

I know it's not scripts because... mine has none besides the defaults. Tried clean installs-- It happens to me in every version back to 5.16 or so.

We found that it's specifically related to when a channel window is made inactive either through minimizing, alt+tab, clicking on the start menu, or switching away from the window in any manner. If you go back to mIRC and type quickly, it'll lag and sometimes not display until you move the mouse.

It types and displays perfectly until this is done.

This behaviour is also specific to each channel window (It doesn't happen in unique channel windows until you switch to them and change the active window).

I run AVG, so I also tried the exception mentioned earlier in this thread. I've also attempted to run it on compatibility modes for XP SP3 (The previous OS I used), SP2, Vista, and for kicks 2000 and 95. It makes no effect.

Otherwise it works beautifully, I've seen no other issues. As stated, it could be something in Windows 7, since it didn't do this to me in XP SP3-- But as I pointed out... the old versions around 5.16 and below don't do this.

Just for sake:
I'm currently using 6.35 edition re-installed
I'm running a Phenom II X4 955 3.2Ghz quad, 4Gb RAM, Windows 7 build 7100 RC, Sapphire Radeon 4870HD, Western Digital Caviar SATA 620Gb HD.


Edited by kogitsune (16/06/09 05:23 AM)

Top
#213048 - 16/06/09 06:44 AM Re: Typing lag mirc 6.35 [Re: kogitsune]
argv0 Offline
Planetary brain

Registered: 13/10/03
Posts: 3918
Loc: Montreal, QC, Canada
@kogitsune: In mIRC type:

//echo -a $md5($mircexe,2) $script(0) $dll(0) $version $os

Report the results here.

Also disable AVG entirely (yes, entirely) and try this again. It's far more likely that your anti-virus software is causing the problem than mIRC.
_________________________
- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"

Top
#213079 - 17/06/09 03:31 PM Re: Typing lag mirc 6.35 [Re: argv0]
westor Offline
Hoopy frood

Registered: 27/12/08
Posts: 1511
Loc: Greece
The same problem here with Windows XP SP3, getting lag on scripts!

3e9f2b048c960052d6230d4735c41622 8 1 6.35 XP
_________________________
Need Online mIRC help or an mIRC Scripting Freelancer? -> http://westor.ucoz.com/contact <-

Top
#213081 - 17/06/09 03:34 PM Re: Typing lag mirc 6.35 [Re: westor]
Wims Offline
Planetary brain

Registered: 31/07/06
Posts: 3438
Loc: France
You don't have a real copy of mIRC 6.35, try download it on mirc.com.Also, unload your scripts and your dll, you really should try on a clean install.


Edited by Wims (17/06/09 03:36 PM)
_________________________
Looking for a good help channel about mIRC? Check #mircscripting @ irc.swiftirc.net

Top
#213906 - 11/07/09 08:19 PM Re: Typing lag mirc 6.35 [Re: Shocky]
DJ_Sol Offline
Hoopy frood

Registered: 04/01/07
Posts: 1156
Loc: Seattle
I wonder what your computers specs are. Been using Vista for over a year and have never had this issue.

Top
#213912 - 11/07/09 09:19 PM Re: Typing lag mirc 6.35 [Re: DJ_Sol]
argv0 Offline
Planetary brain

Registered: 13/10/03
Posts: 3918
Loc: Montreal, QC, Canada
Both users who complained in this thread had modified versions of mIRC, so draw your own conclusions.
_________________________
- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"

Top
#214260 - 26/07/09 09:50 PM Re: Typing lag mirc 6.35 [Re: argv0]
Lusht Offline
Ameglian cow

Registered: 18/08/07
Posts: 42
Loc: Russia
Ok, I tired.
Same annoying problem here, details:
2f63a83968f9586fe4fb48134253619c 23 0 6.35 Vista (it's win7 x32 actually)
Also, additional details:
http://img233.imageshack.us/i/details.png/
Just clean install, it is not modified copy. UTF-8 encoding&decoding (per channel settings) disabled, only UTF-8 display enabled.

Btw, I noticed that when lagging starts such interesting thing happens:
http://img233.imageshack.us/my.php?image=graph.png

If I will quickly change window to text editor - everything fine, no lagging when typing...

P.S. Under Vista it worked fine with the same set of scripts. Also, I don't have script which monitors on INPUT events or editbox state.


Edited by Lusht (26/07/09 09:51 PM)
_________________________
"Do, or do not. There is no 'try'." - Yoda ('The Empire Strikes Back')

Top
#214262 - 26/07/09 10:07 PM Re: Typing lag mirc 6.35 [Re: Lusht]
argv0 Offline
Planetary brain

Registered: 13/10/03
Posts: 3918
Loc: Montreal, QC, Canada
How does a "clean install" contain 23 loaded scripts?

Any number of those 23 scripts could be the cause. Try with a *CLEAN* install of mIRC-- this means without any loaded scripts.

Alternatively you can unload scripts until the problem goes away (if it does)-- the last unloaded script would be the cause, at which point we can figure out if it's the script or some incompatibility between those commands and Windows7.
_________________________
- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"

Top
#214272 - 27/07/09 06:57 PM Re: Typing lag mirc 6.35 [Re: argv0]
Lusht Offline
Ameglian cow

Registered: 18/08/07
Posts: 42
Loc: Russia
Quote:
How does a "clean install" contain 23 loaded scripts?

I said it especially for you to prevent "oh-youre-using-modified-copy!" thingy.

Quote:
Any number of those 23 scripts could be the cause. Try with a *CLEAN* install of mIRC-- this means without any loaded scripts.

TRIED already. Same issue happens.
_________________________
"Do, or do not. There is no 'try'." - Yoda ('The Empire Strikes Back')

Top
#214295 - 28/07/09 06:19 AM Re: Typing lag mirc 6.35 [Re: Lusht]
argv0 Offline
Planetary brain

Registered: 13/10/03
Posts: 3918
Loc: Montreal, QC, Canada
I don't understand your response. If you tried this without scripts why did your post explicitly discuss the results *with* scripts?
_________________________
- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"

Top
#214323 - 28/07/09 10:07 PM Re: Typing lag mirc 6.35 [Re: argv0]
Lusht Offline
Ameglian cow

Registered: 18/08/07
Posts: 42
Loc: Russia
Quote:
I don't understand your response.

We can help here:

Quote:
Try with a *CLEAN* install of mIRC-- this means without any loaded scripts.


Quote:
TRIED already. Same issue happens.
_________________________
"Do, or do not. There is no 'try'." - Yoda ('The Empire Strikes Back')

Top
Page 1 of 2 1 2 >